Mailinglist Archive: yast-devel (25 mails)

< Previous Next >
Re: [yast-devel] yast2-branding-openSUSE missing in TW and 15.1: too small fonts, missing icons

On sob, May 25, 2019 at 10:37 AM, Felix Miata <mrmazda@xxxxxxxxxxxxx> wrote:
Is this intentional? Did something replace it? If so, what?

In Plasma on TW (host big41), and KDE3 (host big41) on 15.1, there are no icons in
YaST2 Control Center. These were previously provided by yast2-branding-openSUSE.

They are no longer provided by the yast2-theme, yast gets icons from modules
themselves, the icons currently in yast2-theme package are only needed for
packager (and oxygen is an exception)...

Icons for breeze are in upstream theme, icons for oxygen are in yast-theme still
(yast2-theme-oxygen package), crystal theme was unmaintained, therefore was removed.

In 15.1/KDE3 (host big41) at least, both yast2 --qt and yast2 --gtk Control Center
use the DE font size, but selections from it such as sw_single, ignore font size
configured whether via qtcontrol or qt5ct or KControl. Fonts are too small, as if
assuming DPI 96 instead of actual higher DPI. If I set Xft.dpi to the actual DE
DPI, then fonts are as much too big as they were too small without it set. e.g.,
with 12pt desired/configured, without Xft.dpi fonts look around 9pt, while with
matching DPI, they look around 15pt. In no case with KDE3 or TDE do font sizes in
YaST2 Control Center match those in YaST2 Software. (They do in Plasma.)

In 15.1/TDE (host GB250), fonts in Control Center are too small (same size as in
KDE3), and ignore Xft.dpi.

Maybe it's related with:
https://bugzilla.opensuse.org/show_bug.cgi?id=1123424

LCP [Stasiek]
https://lcp.world


--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References