Mailinglist Archive: yast-devel (42 mails)

< Previous Next >
[yast-devel] Travis Update: Ubuntu 12.04 EOL

Hi all,

Travis runs Ubuntu 12.04 in some jobs but Canonical is ending
the official support on April 28th (i.e. this Friday).

Some notes:

- Travis builds will still use the 12.04 version even after
the EOL date.

- Upgrade to Ubuntu 14.04 LTS is planned at Q3 (probably at July)
(ugh? I'd expect upgrade to 16.04 LTS to avoid the same
situation soon...)

See more details at https://blog.travis-ci.com/2017-04-17-precise-EOL


How this will affect us?

- As we switched to Docker at Travis and run the builds
inside an openSUSE Tumbleweed container this should not affect
us at all in the "master" branch. Moreover it seems that for
the "master" branch Travis already uses the 14.04 version.
(I have checked few packages and all were running in 14.04.)

- However, the problem can be expected with the SLE-12-SP2 branch
and older as these still run in 12.04.

That means we will probably need to switch to Docker also in
the older branches, at least in SP2 + CASP, SP1 would be nice
as well I guess.

(An alternative approach could be building the packages in OBS
for the 14.04 version but that might be tricky so I'd prefer
the Docker solution.)


I have created a Trello card to track it: https://trello.com/c/V0OaC4DT



--
Ladislav Slezák
YaST Developer

SUSE LINUX, s.r.o.
Corso IIa
Křižíkova 148/34
18600 Praha 8
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages