Mailinglist Archive: yast-devel (87 mails)

< Previous Next >
[yast-devel] Solving Simplecov and Coveralls issues at Travis

Hello,

If you get "Unable to activate coveralls-0.8.19, because simplecov-0.13.0
conflicts
with simplecov (~> 0.12.0)" error at Travis then remove the "simplecov" gem
installation from the ".travis.yml" file. (See example [1].)

The correct "simplecov" version will be automatically installed as a coveralls
dependency.


JFYI: This error can happen only in the old SP2/CASP branches, `master` already
uses
Docker and the packages are installed as RPMs (where the dependencies are
checked before installing the gems).


[1]
https://github.com/yast/yast-packager/pull/227/commits/bd4e1a2693972645d591d5f5a725e91bb5b2ce3f



--
Ladislav Slezák
YaST Developer

SUSE LINUX, s.r.o.
Corso IIa
Křižíkova 148/34
18600 Praha 8
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages