Mailinglist Archive: yast-devel (53 mails)

< Previous Next >
Re: [yast-devel] Re: SP3 and factory have different binary sources
On Fri, Jan 20, 2017 at 01:51:18PM +0100, Ladislav Slezak wrote:
Dne 19.1.2017 v 14:20 Ludwig Nussel napsal(a):
No idea :-) You'd have to try to see if the result is identical.

I have tried that tar command manually and it works, the recreated
tarball has the same SHA1 sum.

But it is be a bit tricky to incorporate this into the rake task.

We use the standard Rake::PackageTask class for this, it allows
to optionally specify the "tar" command, but it does not allow
to pass additional parameters :-(

I tried a trick with tar_command = "tar --mtime=@0 --owner=0 ..."
but that does not work as the options must be placed after the
"jcfv" command otherwise it fails with an argument error.

So my PoC solution [1] simply creates the target directory
and builds the tarball with Rake::PackageTask and then repackages the
directory again using the extra tar options.

The only drawback is that the files in the tarball have zero timestamps
(01-01-1970), which IMO is not nice as sometimes they are useful :-(

Set the file timestamps to the last file modification in
git. That should give useful timestamps and identical tars.

ciao Arvin

PS: In general setting the timestamps is considered "stupid"
since it breaks 'make'.

Arvin Schnell, <aschnell@xxxxxxxx>
Senior Software Engineer, Research & Development
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)
Maxfeldstraße 5
90409 Nürnberg
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >