Mailinglist Archive: yast-devel (79 mails)

< Previous Next >
[yast-devel] Yast and rubygems dependencies
Hi,
as disclosured by recent openqa testing, yast have to fix dependency on
rubygems to always use system ruby ABI ( as it use system ruby and
gems with different ruby ABI cannot be used together). So if you add any
rubygem then please fix ruby ABI.

way how to specify it:

Requires: rubygem(%rb_default_ruby_abi:cheetah)

instead of plain

Requires: rubygem(cheetah)

Thanks
Josef
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages