Mailinglist Archive: yast-devel (91 mails)

< Previous Next >
Re: [yast-devel] installer can't find existing BIOS partitions
On Thu, 28 Jan 2016 17:56:24 -0500
Felix Miata <mrmazda@xxxxxxxxxxxxx> wrote:

Athlon XP (32bit)
I just tried twice with TW 20160126 to initialize installation. At
suggested partitioning screen:

No automatic proposal possible. Specify mount points manually
in the 'Partitioner' dialog.

YaST claims no partitions on sda, an "unused" device.

On vtty2, results from fdisk (30 partitions on 160G HD[1]) and mount
(success with two ext3 filesystems tried) are totally as expected.
lsmod | grep ata shows ata_generic, pata_via and libata.

Is this a known problem?

Any way to restart YaST without reboot? This system is taking about 8
minutes to boot to the initial license screen. The installed 11.2,
11.4, 12.1, 12.2, 12.3, 13.1, 13.2, TW and Fedoras on it are/were all
behaving normally when last tried.

Dmesg inexplicably lists lots of floppy I/O errors and mentions of
device-mapper and raid6, plus one each raid6, raid5, raid4, raid10.
Also listed are all of sda1-sda30.

Is this worth a bug report?

logs: http://fm.no-ip.com/Tmp/SUSE/Factory/y2ltwkt400.tgz

[1] http://fm.no-ip.com/Tmp/SUSE/Factory/kt400L14.txt

I see in logs a lot of errors regarding reading partitions info:

2016-01-28 13:32:58 <3> kt400(3222) [libstorage]
ProcParts.cc(getSize):92 dev:sda30 not found
2016-01-28 13:32:58 <1> kt400(3222) [libstorage]
Disk.cc(checkPartedOutput):532 nm:sda
2016-01-28 13:32:58 <3> kt400(3222)
[libstorage] ../storage/Utils/StorageTmpl.h(read_sysfs_property):288
reading /sys/block/sda/sda1/start failed
2016-01-28 13:32:58 <3> kt400(3222)
[libstorage] ../storage/Utils/StorageTmpl.h(read_sysfs_property):288
reading /sys/block/sda/sda1/size failed
2016-01-28 13:32:58 <3> kt400(3222) [libstorage]
Disk.cc(checkPartitionsValid):602 region mismatch dev:/dev/sda nr:1
sec_parted:[63,497952] sec_kernel:[0,0]


So please check in insts-sys why reading of /sys/block/sda/sda1/size
failed. For me it looks like potentatial problem in kernel, as sysfs is
provided by kernel. So I think worth creating bug report, so it can be
pointed where exactly is problem.
Last log entry shows difference between partition reported by parted
and kernel, so probably something between them.

Josef
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
References