Mailinglist Archive: yast-devel (91 mails)

< Previous Next >
Re: [yast-devel] YCP Killer appliance
On Thu, 07 Jan 2016 21:45:54 +0100
Christian Boltz <opensuse@xxxxxxxxx> wrote:

Hello,

Am Donnerstag, 7. Januar 2016 schrieb Erico Mendonca:
I installed and tested y2r on Ruby 1.8, 2.1 and 2.3 on SLES 11 SP4
using the packages from devel:languages:ruby. They all fail with the
same syntax errors on y2r code. I’m afraid I’m too much of a newbie
on Ruby to take it on. Could someone help here?

I'm not an YCP, ruby or YaST expert, but -

IIRC openSUSE 13.1 was the first with ruby-based YaST.

Therefore I'd recommend to setup a VM with openSUSE 12.3, which most
probably has the package versions that were used back then. (Maybe
newer-than-12.3 Factory was used, but 12.3 should be close enough.)

I'd also guess that this will work out much faster than hunting down
one error after the other ;-)

(It might also be a good idea to keep that VM in case someone needs
it again ;-)


Regards,

Christian Boltz

Yes, Christian is right. I recommend to use 13.2 or Leap for such kind
of operation. SLE12 SP1 is also good for it. SLE11 is just too old for
such operation.

Josef
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >