Mailinglist Archive: yast-devel (211 mails)

< Previous Next >
Re: [yast-devel] yast2 --qt requires unavailable libyui6
On Fri, Oct 16, 2015 at 05:26:40PM -0400, Felix Miata wrote:
RE: http://lists.opensuse.org/opensuse-factory/2015-10/msg00474.html

Is requirement of unavailable libyui6 expected behavior on TW? Shouldn't
presence of libyui7 and deps cause removal of libyui6 and deps? Is this a
misfortune of following widespread recommendation to use up rather than dup
to upgrade TW?

Hi!

as others have mentioned, libyui7 intentionally does not obsolete
libyui6. This is so that you are able to have them both used by
different programs/libraries.
For YaST, the requiring component is yast2-ycp-ui-bindings:

# rpm -qia --requires yast2-ycp-ui-bindings
Name : yast2-ycp-ui-bindings
Version : 3.1.9
Release : 1.3
Architecture: x86_64
Install Date: Fri Oct 9 09:53:32 2015
...
libyui.so.7()(64bit)
...

Then on the way down, libyui7.rpm requires 'yui_backend = 7' which
can be fulfilled EITHER by libyui-ncurses7 OR libyui-qt7.

I hope this explains the situation a bit. In the original Factory
post, Kyrill was able to fix the problem once he remembered to query
for "libyui".
--
Martin Vidner, YaST Team
http://en.opensuse.org/User:Mvidner

Kuracke oddeleni v restauraci je jako fekalni oddeleni v bazenu
< Previous Next >
Follow Ups
References