Mailinglist Archive: yast-devel (211 mails)

< Previous Next >
Re: [yast-devel] yast2 --qt requires unavailable libyui6
Dne 16.10.2015 v 23:26 Felix Miata napsal(a):
RE: http://lists.opensuse.org/opensuse-factory/2015-10/msg00474.html

Is requirement of unavailable libyui6 expected behavior on TW? Shouldn't
presence of libyui7 and deps cause removal of libyui6 and deps? Is this a
misfortune of following widespread recommendation to use up rather than dup
to upgrade TW?


Um, I'm not a packaging expert, but for me it looks like the dependency
is somewhat broken:

# rpm -q --obsoletes libyui7
yast2-libyui < 2.42.0
# rpm -q --provides libyui6
libyui.so.6()(64bit)
libyui6 = 3.1.4-1.8
libyui6(x86-64) = 3.1.4-1.8
yast2-libyui = 2.42.0

So libyui7 does not obsolete libyui6 because the obsolete version
does not match the libyui6 version...


Martin?



--

Ladislav Slez√°k
Appliance department / YaST Developer
Lihovarsk√° 1060/12
190 00 Prague 9 / Czech Republic
tel: +420 284 028 960
lslezak@xxxxxxxx
SUSE
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References