Mailinglist Archive: yast-devel (25 mails)

< Previous Next >
Re: [yast-devel] Versioning yast-security
  • From: Ancor Gonzalez Sosa <ancor@xxxxxxx>
  • Date: Wed, 23 Sep 2015 15:20:28 +0200
  • Message-id: <5602A71C.7040204@suse.de>
On 09/22/2015 11:19 PM, Ladislav Slezak wrote:
Dne 22.9.2015 v 18:50 Ancor Gonzalez Sosa napsal(a):
[...]
That will lead to version 3.11.1.2 in SLE-12-GA but... which version
number should I use in the SLE-12-SP1 branch?

The version in SLE-12-SP1 must be greater than any (future) version in
SLE-12-GA to
correctly update the package during upgrade from GA to SP1 (otherwise the
solver
would keep the old version).

That means the version must be 3.11.2 in SLE-12-SP1.

That will collide to what I was expecting to do for SLE-12-GA.

Now we have
SLE-12-GA: 3.1.11.1
SLE-12-SP1: 3.1.11
Master: 3.1.12

Your suggestion
SLE-12-GA: ?? I need to increase this one.
SLE-12-SP1: 3.1.11.2
Master: 3.1.12

I guess you actually meant
SLE-12-GA: 3.1.11.2
SLE-12-SP1: 3.1.12.1
Master: 3.1.12

Isn't it?

--
Ancor González Sosa
YaST Team at SUSE Linux GmbH
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups