Mailinglist Archive: yast-devel (72 mails)

< Previous Next >
[yast-devel] Added openSUSE_13.2_Update target to YaST:Head

Hi all!

If you use the Yast packages from YaST:Head (you should ;-))
on 13.2 you might have seen a conflict for packages using libzypp, like
yast2-pkg-bindings or libyui-*-pkg packages.

The problem is that there was released a libzypp update for 13.2
which contains a new *.so library. That means it is incompatible
with the original package.

The solution is to build YaST:Head against the openSUSE_13.2_Update
repository.

The question is whether we still need to build the packages for the original
openSUSE_13.2 (without updates). Using the latest YaST packages on an "old" 13.2
sounds weird to me, if you want the edge YaST packages I suppose you also want
the
base system to be up to date.


*** IMPORTANT! ***

So if nobody objects I'd remove the openSUSE_13.2 target to save the
OBS resources, it does not make sense to build the packages twice.

I'd remove it this Friday (Apr 24) around 14:00 CEST.

Do not forget to update your YaST:Head repository URL [1]!

*** IMPORTANT! ***



Of course, you can use the openSUSE_13.2_Update YaST packages on the original
13.2,
the packages will be the same except the packages mentioned at the beginning.

So we basically move the package conflict from updated 13.2 to
unpatched 13.2, that should be fine I think...



[1] http://download.opensuse.org/repositories/YaST:/Head/openSUSE_13.2_Update

Note: it still does not work, the repo has not been published yet although
the
packages have been built, the OBS is somehow slow today... :-(

--

Ladislav Slez√°k
Appliance department / YaST Developer
Lihovarsk√° 1060/12
190 00 Prague 9 / Czech Republic
tel: +420 284 028 960
lslezak@xxxxxxxx
SUSE

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages