Mailinglist Archive: yast-devel (72 mails)

< Previous Next >
Re: [yast-devel] yast2-auth-server fails to build with GCC 5 (fwd)
Hi,
I think you did it right to write ckornacker and varkoly, they are
maintainers of yast2-auth-server. YaST team itself do not handle it,
just do mass changes affecting all modules.

Just to know, SR against package is useless, you have to modify it on
github. Otherwise next automatic submission from git remove it.

Josef


On Fri, 10 Apr 2015 13:26:32 +0200 (CEST)
Richard Biener <rguenther@xxxxxxx> wrote:


Just to make sure this doesn't get lost (SRs against package are
not accepted).

Richard.

---------- Forwarded message ----------
Date: Thu, 9 Apr 2015 10:51:07 +0200 (CEST)
From: Richard Biener <rguenther@xxxxxxx>
To: ckornacker@xxxxxxxx, varkoly@xxxxxxxx
Subject: yast2-auth-server fails to build with GCC 5


See patch below (default args are not valid in a typedef context).

Thanks,
Richard.

--- yast2-auth-server-3.1.13/lib/slapd-config.h.orig
2015-04-09 10:47:38.777711978 +0200 +++
yast2-auth-server-3.1.13/lib/slapd-config.h 2015-04-09

10:47:45.377785905 +0200 @@ -28,7 +28,7 @@ #define SLAPD_LOG_ERR 1

typedef void (SlapdConfigLogCallback) (int level, const std::string
&msg,
- const char* file=0, const int line=0, const char*
function=0 );
+ const char* file, const int line, const char* function );

class OlcConfigEntry
{

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
References