Mailinglist Archive: yast-devel (53 mails)

< Previous Next >
Re: [yast-devel] y2makeport of devtools broken?
On Thu, 13 Feb 2014 22:21:49 +0100
Ladislav Slezak <lslezak@xxxxxxx> wrote:

Dne 9.2.2014 00:53, Andreas Buschka napsal(a):
Hello @all,

I tried to translate some of the new strings in the current
installation program, however, my copy of y2makepot (from factory)
seems to be broken. Can anyone help?

ab@linux-btu0:~/yast-checkout/yast2base/installation>
/usr/share/YaST2/data/devtools/bin/y2makepot
/usr/share/YaST2/data/devtools/bin/y2makepot: line 17:
/usr/share/YaST2/data/devtools/bin/gettextdomains: No such file or
directory /usr/share/YaST2/data/devtools/bin/y2makepot: line 113:
get_domains_and_err: command not found

Josef, IIRC you did some cleanup in devtools, maybe this was lost by
mistake... Could you check it?



Lada,
I found script - >
https://github.com/yast/yast-devtools/blob/Code-11-SP2/devtools/bin/gettextdomains

It prints domains of given files and error where domain is not
specified. Do you still need it for pot generation?

It is called in this line
https://github.com/yast/yast-devtools/blob/886e517de02cef670e61654e6cf0fee78066ee36/build-tools/scripts/y2makepot#L113
and fills variables $ERR, $DOMAINS and others that are not used. So is
it still needed? If so, then we need to get it back and hugely modify
it to support ruby there.

Josef
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups