Mailinglist Archive: yast-devel (128 mails)

< Previous Next >
Re: [yast-devel] WebYaST initialization got stuck with error: Permission org.opensuse.yast.modules.yapi.administrator.read is not granted for user root
  • From: "Hai Shi" <HShi@xxxxxxxxxx>
  • Date: Fri, 19 Feb 2010 14:16:45 -0700
  • Message-id: <4B7EB96D0200001200020058@xxxxxxxxxxxxxxxxxxxxx>
Hi, Josef:
I created another appliance build and this time the initialization get stuck at
Registration:

No permissions for registration

Thanks,
Hai


"Hai Shi" <HShi@xxxxxxxxxx> 2/19/2010 10:24 AM >>>
Hi, Josef:
I used the webyast respository from:
zypper ar http://www.suse.de/~mvidner/webyast-gmc webyast-gmc
zypper ar http://www.suse.de/~mvidner/webyast-lighty webyast-lighty

yast2-webservice-administrator package version is 0.0.9-0.1.1.

There is no "/var/log/zypp/history" file.

linux-sdc3:~ # cd /var/log/zypp/
linux-sdc3:/var/log/zypp # ls
linux-sdc3:/var/log/zypp # polkit-auth --user root | grep
org.opensuse.yast.modules.yapi.administrator.read
org.opensuse.yast.modules.yapi.administrator.read
linux-sdc3:/var/log/zypp # polkit-auth --user yastws | grep
org.opensuse.yast.modules.yapi.administrator.read
org.opensuse.yast.modules.yapi.administrator.read

Thanks,
Hai

Josef Reidinger <jreidinger@xxxxxxx> 2/19/2010 3:27 AM >>>
Hai Shi write:
Hi,
I am working on include WebYaST in the appliance. I followed the WebYaST
vendor's guide:
http://www.novell.com/documentation/webyast/book_webyast_vendor/?page=/documentation/webyast/book_webyast_vendor/data/cha_webyast_vendor_overview.html


WebYaST initialization got stuck after accepting the license with error:
Permission org.opensuse.yast.modules.yapi.administrator.read is not granted
for user root

The appliance is vmware image and has 2G memory. I used SUSE Sudio Online to
build the appliance.

Thanks,
Hai


Hi,
could you please specify what version of webyast-administrator-ws is in
appliance?
Permissions should be set in post install script so please look also at
/var/log/zypp/history where could be some error report.
And if you have not edge version it can be also problem with yastws rights. So
please try in appliance this two commands which specify which permission really
missing:
polkit-auth --user root | grep
org.opensuse.yast.modules.yapi.administrator.read #if nothing is showed then
root doesn't have rights
polkit-auth --user yastws | grep
org.opensuse.yast.modules.yapi.administrator.read #if nothing is showed then
yastws doesn't have rights

Thanks

--
Josef Reidinger
YaST team
maintainer of perl-Bootloader, YaST2-Repair, parts of webyast
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx


--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx


--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References