Mailinglist Archive: yast-devel (126 mails)

< Previous Next >
Re: [yast-devel] Re: [yast-commit] Build failed in Hudson:
  • From: Josef Reidinger <jreidinger@xxxxxxx>
  • Date: Wed, 11 Nov 2009 15:27:07 +0100
  • Message-id: <200911111527.07543.jreidinger@xxxxxxx>
No it is not packaging problem, It is problem in hudson script ( I grep whole
git repository when I change name), which uses old name of granting script. I
fix it now (it is little tricky to find that make_zypp is binary which build
webyast :) ).
If another problem occur I look at it.

Josef

Klaus Kaempf write:
Now that git is back up, this is a real packaging error :-}

Klaus

* Hudson Integration Service <hudson@xxxxxxx> [Nov 11. 2009 14:57]:
See http://yast.suse.de:3334/job/webyast-service-head-i586/596/changes

Changes:

[Josef Reidinger] fix removing files from package in osc_submit task,
release 0.0.10

[Josef Reidinger] rename script for grnating webyast rights and place
to proper location (bnc#542077)

[Josef Reidinger] don't automatic use index.php, as we not use php
for webyast

[Stefan Schubert] version 0.0.7

[Stefan Schubert] Merge branch 'master' of
git@xxxxxxxxxxxxxxxx:projects/yast/rest-service

[Stefan Schubert] added doc files

------------------------------------------
A SCM change trigger started this job
Checkout
[workspace] $ git fetch
Checking out origin/master
[workspace] $ git checkout -f origin/master
Previous HEAD position was c9c9108... fix version of yast2-network
HEAD is now at 42c2433... added doc files
[workspace] $ git rev-parse origin/master
[workspace] $ git log --numstat -M --summary --pretty=raw
329b2610999c8f4478c3feb948ef7d66520652fe..42c243333c783c05bacb80a01d7aae2
d9e9c3499 [locks-and-latches] Checking to see if we really have the locks
[locks-and-latches] Have all the locks, build can start
[workspace] $ /bin/sh -xe /tmp/hudson1681495046727357549.sh
+ sudo -E /data/hudson/bin/build-chroot.sh webyast rest-service head-i586
SCRIPT ID: I am /data/hudson/bin/build-chroot.sh at
http://yast.suse.de:3334/job/webyast-service-head-i586/ws/ ..copying
source code http://yast.suse.de:3334/job/webyast-service-head-i586/ws/*
/data/hudson/HUDSON-CHROOT/webyast-head-i586/src/rest-service ..copying
make script to /data/hudson/HUDSON-CHROOT/webyast-head-i586/root ...
mounting sys
... mounting proc
... mounting pts
mount: special device none does not exist
Can't mount devpts /data/hudson/HUDSON-CHROOT/webyast-head-i586/dev/pts
... switching to chroot and starting build
SCRIPT ID: I am /root/make-zypp.sh at /

??,????????'????????,????,????????'????????,????,????????'????????,????,?
???????'????????,????,????????'????????,??

+ echo webyast-rest-service
webyast-rest-service
+ case "${MODULE}" in
+ SUBDIR=webservice
+ cd /src/rest-service
+ echo /src/rest-service
/src/rest-service
+ ls
INSTALL
Makefile
README
Rakefile
doc
index.html.template
plugins
policy-tools
rpam
ruby-polkit
webservice
webservice-tasks
+ [[ rest-service == \r\e\s\t\-\s\e\r\v\i\c\e ]]
+ echo 'start dbus..'
start dbus..
+ /etc/init.d/dbus start
Starting D-Bus daemon..done
+ echo 'Running as root'
Running as root
+ echo 'Test plain SCR call'
Test plain SCR call
+ echo '`Read(.target.tmpdir)'
+ /usr/lib/YaST2/bin/y2base -l - stdio scr
2009-11-11 13:50:47 <1> golelet(4490) [liby2]
genericfrontend.cc(main):668 Launched YaST2 component 'y2base' '-l' '-'
'stdio' 'scr' 2009-11-11 13:50:47 <1> golelet(4490) [ui-component]
YUIComponentCreator.cc(createInternal):113 Creating UI component for ""
2009-11-11 13:50:47 <1> golelet(4490) [liby2]
genericfrontend.cc(main):822 YAST_IS_RUNNING is yes ([])
("/tmp/YaST2-04490-PYIGFy")
((nil))
2009-11-11 13:50:47 <2> golelet(4490) [liby2]
Y2StdioComponent.cc(doActualWork):120 Communication ended prior to result
() message 2009-11-11 13:50:47 <1> golelet(4490) [liby2]
genericfrontend.cc(main):837 Finished YaST2 component 'y2base' 2009-11-11
13:50:47 <1> golelet(4490) [liby2] genericfrontend.cc(main):842 Exiting
with client return value 'nil' + check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ case "${MODULE}" in
+ echo 'Creating shared tasks gem'
Creating shared tasks gem
+ pushd webservice-tasks
/src/rest-service/webservice-tasks /src/rest-service
+ rake package-local
gem build yast2-webservice-tasks.gemspec
(in /src/rest-service/webservice-tasks)
Updating yast2-webservice-tasks.gemspec (0.0.10)...
Updating package/rubygem-yast2-webservice-tasks.spec (0.0.10)...
WARNING: no description specified
WARNING: no rubyforge_project specified
Successfully built RubyGem
Name: yast2-webservice-tasks
Version: 0.0.10
File: yast2-webservice-tasks-0.0.10.gem
cp yast2-webservice-tasks-0.0.10.gem package
+ echo 'Installing gem...'
Installing gem...
+ gem install yast2-webservice-tasks-0.0.10.gem
ERROR: http://gems.rubyforge.org/ does not appear to be a repository
Successfully installed yast2-webservice-tasks-0.0.10
1 gem installed
Installing ri documentation for yast2-webservice-tasks-0.0.10...
Installing RDoc documentation for yast2-webservice-tasks-0.0.10...
+ popd
/src/rest-service
+ sudo rake install_policies
(in /src/rest-service)
(in /src/rest-service/webservice)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/time)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/patches)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/users)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/network)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/basesystem)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/samba_server)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/system)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/administrator)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/registration)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/mail_settings)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/securities)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/language)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/services)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/eulas)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/ntp)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake (in
/src/rest-service/plugins/status)
Running from
/src/rest-service/webservice-tasks/lib/tasks/install_policies.rake +
check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ cat
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ pushd webservice
/src/rest-service/webservice /src/rest-service
+ ruby package/policyKit-rights.rb --user root --action grant
ruby: No such file or directory -- package/policyKit-rights.rb
(LoadError) ++ error_exit 1
++ echo 'ERROR: detected exit code 1'
ERROR: detected exit code 1
++ footer_and_exit 1
++ '[' -z 1 ']'
++ MYEXIT=1
++ '[' 1 == 0 ']'
++ ascii_failed
++ cat

( )
( ) (
) _ )
( \_
_(_\ \)__
(____\___))

build failed

++ echo 'stopping dbus..'
stopping dbus..
++ /etc/init.d/dbus stop
Shutting down D-Bus daemon..done
++ exit 1
... unmounting sys
... unmounting proc
... unmounting pts
umount: /data/hudson/HUDSON-CHROOT/webyast-head-i586/dev/pts: not mounted
Can't unmount devpts /data/hudson/HUDSON-CHROOT/webyast-head-i586/dev/pts
[locks-and-latches] Releasing all the locks
[locks-and-latches] All the locks released
Publishing Javadoc
Archiving artifacts
Build wasn't successful, skipping saikuro coverage report
Publishing rails stats report...
[workspace] $ rake --silent stats
Failed to send e-mail to Stefan Schubert because no e-mail address is
known, and no default e-mail domain is configured

---
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG N├╝rnberg)


--
Josef Reidinger
YaST team
maintainer of perl-Bootloader, YaST2-Repair, webyast
(language,time,basesystem,ntp)
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References