Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
Re: [yast-devel] Webyast - Po files and generating mo files
  • From: Josef Reidinger <jreidinger@xxxxxxx>
  • Date: Fri, 16 Oct 2009 11:03:05 +0200
  • Message-id: <200910161103.05412.jreidinger@xxxxxxx>
Josef Reidinger write:
Josef Reidinger write:
Stefan Schubert write:
Josef Reidinger schrieb:
Hi,
today I try rake makemo to test how it works and when add it to rake
push. But It fails for me everytime I run it, even if I regenerate po
files via rake updatepot.

error is:
jreidinger@zofie:~/webyast/web-client/plugins/systemtime> rake makemo
(in /home/jreidinger/webyast/web-client/plugins/systemtime)
./po/de/yast_webclient_systemtime.po ->
./locale/de/LC_MESSAGES/yast_webclient_systemtime.mo ... rake
aborted! undefined method `size' for nil:NilClass

(See full trace by running task with --trace)


Does anyone have idea what is wrong?

Hi,
I have seen this error also on Martin V. machine but were not able to
reproduce.
This error has also happened in autobuild. The reason for was a none
set LANG
env variable. So I have put

%build
export RAILS_PARENT=/srv/www/yast
env LANG=en rake makemo

to the spec file.

Does that help ?

Greetings
Stefan

Hi, it doesn't help. I think it is related to some machine state, as if I
move de to another location, then problem disappear. I try rename it to
cs_CZ which is my locale, but problem is still present.

I try debug it and print here result.

OK, I analyze problem and find, that problem is cause if in po file is
present fuzzy string
if you add #, fuzzy
to po file, then rake makemo failed. I try it with English translation that
works.
If I translate string, then everything is fine, but if you add #,fuzzy then
rake makemo fail.


OK, after debugging of parser I find where is problem. Parser for fuzzy
strings call localized string, that fuzzy strings is ignored. But locatization
is not finded and it fails (really funny). I am not sure how to fix it. If I
manually copy localization from gem to usr/share/locale, it still doesn't
help. What helps is if I remove localization from Parser. (I try also latest
version 2.0.4 and it has same problem).

--
Josef Reidinger
YaST team
maintainer of perl-Bootloader, YaST2-Repair, webyast modules language and time
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >