Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
Re: [yast-devel] Yast Memory Error
  • From: Ladislav Slezak <lslezak@xxxxxxx>
  • Date: Thu, 15 Oct 2009 13:17:14 +0200
  • Message-id: <4AD704BA.8070501@xxxxxxx>
On 15.10.2009 11:34, Klaus Kaempf wrote:
* Martin Vidner <mvidner@xxxxxxx> [Oct 15. 2009 11:14]:

OK, most packages have 2.17.x version, which corresponds to openSUSE
11.1, but some of them have 2.18.x (oS 11.2), in particular
yast2-ycp-ui-bindings-2.18.5-1.1
The crash happens in Wizard.ycp which deals with UI code, so it is
most likely a binary incompatiblity of that package.

rpm -V should report such wrong dependencies. If it doesn't, its a
packaging fault (not requiring the correct version).

The dependencies are usually defined like this:

Requires: yast2 >= 2.16.46

We would have to add explicit

Requires: yast2 < 2.18.0

to ensure that 2.18.x package will not be installed.

AFAIK we would have to add this extra dependency for all Requires
for all Yast packages and we would have to change this dependency for each
distribution release.

Maybe this extra dependencies could be added automatically by '/usr/bin/y2tool
create-spec' call which generates the final .spec file from .spec.in.

Or is there a better way?

--

Best Regards

Ladislav Slez√°k
Yast Developer
------------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: lslezak@xxxxxxx
Lihovarsk√° 1060/12 tel: +420 284 028 960
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups