Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
Re: [yast-devel] mail server rest API proposal
  • From: Klaus Kaempf <kkaempf@xxxxxxx>
  • Date: Thu, 8 Oct 2009 13:43:12 +0200
  • Message-id: <20091008114312.GA12431@xxxxxxxxxxxxx>
* Jiří Suchomel <jsuchome@xxxxxxx> [Oct 08. 2009 13:28]:
On Thursday 08 of October 2009 13:17:49 Klaus Kaempf wrote:

singleton class MailServer

I wonder if 'MailServer' is detailed enough.
How would we name the class for configuring a local smtp server ?

Well, that's why I originally chose Mail, not MailServer.

Now 'Mail' would have even less detail. Ideally, the class name itself
would contain enough information to know which kind of resource it

string smtp_server
string login
string password
string tls

What is tls ?

Security layer. Possible values are NONE, MAY, MUST.

What's wrong with naming it transport_layer_security ?


URL: /mail

The URI should add more detail. Long term, WebYaST might need to
support managing local mails, a local smtp server, procmail, etc.

I hope the URL should be the same as name of the model class... which means I
am not sure what to choose.

In Rails, the Controller name determines the URL.


SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)

To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups