Mailinglist Archive: yast-devel (152 mails)

< Previous Next >
Re: [yast-devel] RFC: splitting yast2-core package
  • From: Arvin Schnell <aschnell@xxxxxxx>
  • Date: Wed, 29 Jul 2009 14:11:48 +0200
  • Message-id: <20090729121148.GA13683@xxxxxxx>
On Wed, Jul 29, 2009 at 01:18:52PM +0200, Ladislav Slezak wrote:

Currently yast2-core package requires also DBus and PolicyKit packages
(because of
the DBus service and the DBus agent).

This makes updating or compiling the interpreter more complicated and the DBus
service is always installed (even when not needed) which is bad from security
point
of view.

So my proposal is to split the package into three parts:
- yast2-core - the core interpreter + agents (no DBus or PolicyKit dependency)
- yast2-dbus-client - the DBus agent (requires DBus),
currently needed by yast2-storage only
- yast2-dbus-server - YaST DBus services (require DBus + PolicyKit),
needed by WebYast (so it should not be installed by default)

I have already prepared the new packages in tmp/lslezak SVN branch, RPMs are
in my
OBS project (home:lslezak:Factory).

Please review the proposal. If there are no objections I'll submit the
packages to
Factory soon...

Fine with me. Please add yast2-dbus-client to the required
packages of yast2-storage.

ciao Arvin

--
Arvin Schnell, <aschnell@xxxxxxx>
Senior Software Engineer, Research & Development
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG N├╝rnberg)
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
References