Mailinglist Archive: yast-devel (152 mails)

< Previous Next >
[yast-devel] TraditionalYaST: Check unsupported in/out paramter to Pkg::PkgUpdateAll (pkg-bindings,update_proposal.ycp,Wagon.ycp,???)
  • From: Michael Andres <ma@xxxxxxx>
  • Date: Wed, 8 Jul 2009 15:57:14 +0200
  • Message-id: <200907081557.15332.ma@xxxxxxx>

Hi!

(in svn/yast/trunk)

Pkg::PkgUpdateAll internally calls zypp::Resolver::doUpgrade to perform the
distribution upgrade. Since 11.1 we're using libsatsolver for this and any
provided input arguments are obsolete, and returned statistic values are fake
(allways 0).


Removing this outdated UpgradeStatistics stuff from libzypp, I found that some
YCP code (update_proposal.ycp,Wagon.ycp) still passes options to
Pkg::PkgUpdateAll (e.g. 'silent_downgrades') or evaluates values in the
returned map (e.g. 'ProblemListSze').

I fixed Pkg::PkgUpdateAll to no longer refer to the UpgradeStatistics class,
and so it now returns an empty map. (pkg-bindings-2.18.8)


But the YCP code calling Pkg::PkgUpdateAll should be reviewed. Either those
in/output values can be cleaned up, or we need to invent some substitute for
the desired functionality (although no one seems to have missed something in
code11).

--

cu,
Michael Andres

+------------------------------------------------------------------+
Key fingerprint = 2DFA 5D73 18B1 E7EF A862 27AC 3FB8 9E3A 27C6 B0E4
+------------------------------------------------------------------+
Michael Andres YaST Development ma@xxxxxxxxxx
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nuernberg)
Maxfeldstrasse 5, D-90409 Nuernberg, Germany, ++49 (0)911 - 740 53-0
+------------------------------------------------------------------+

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages