Mailinglist Archive: yast-devel (116 mails)

< Previous Next >
Re: [yast-devel] DnsServerAPI.pm
  • From: Lukas Ocilka <lukas.ocilka@xxxxxxx>
  • Date: Wed, 11 Jun 2008 13:37:46 +0200
  • Message-id: <484FB90A.6010103@xxxxxxx>
Stanislav Visnovsky wrote:
Dňa Tuesday 10 June 2008 14:55:14 Duncan Mac-Vicar Prett ste napísal:
Lukas Ocilka wrote:
Another solution would be to move that library to yast2-dns-server-API
package. Would it help? Do we want a package with one relatively small
library (plus docu?).

L.
ugh, yes, that is what I proposed above.

Instead of

yast2-http -> yast2-dns-server

or
yast2-http ->
yast2-dns-server -> yast2 -> libzypp and more

yast2-http ->
yast2-dns-server -> yast2-modules-dns

yast2-api-dns?

I'd rather use $package-api for building and .spec file purpose.

~~~> Recommends
---> Requires

yast2-dns-server-api ~~~> yast2-dns-server
yast2-http-server ---> yast2-dns-server-api
yast2-dhcp-server ---> yast2-dns-server-api

yast2-slp-api ~~~> yast2-slp
yast2-ntp-client ---> yast2-slp-api

Finally, the system will end up with yast2-dns-server (plus deps.) installed but one can remove it as it is only recommended :)

Any comments?
Thx && Bye
L.

< Previous Next >
Follow Ups