Mailinglist Archive: yast-devel (122 mails)

< Previous Next >
[yast-devel] Re: [opensuse-factory] Problems with yast2
  • From: Lukas Ocilka <lukas.ocilka@xxxxxxx>
  • Date: Wed, 12 Dec 2007 12:34:50 +0100
  • Message-id: <475FC75A.5090105@xxxxxxx>
Markus Koßmann wrote:
After updating my factory installation yesterday evening " yast2 sw_single"
fails with:
635 Error while creating client module sw_single

y2log shows
[...]
2007-12-11 19:38:23 <1> linux-n04x(5049) [wfm] Y2WFMComponent.cc(import):698
Y2WFMComponent::import (SlideShow)
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Loading module 'Language' failed
2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Import.cc(import):97 No
matching component found
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Import 'Language' failed...
2007-12-11 19:38:23 <3> linux-n04x(5049) [Interpreter]
clients/sw_single.ycp:21 Could not create its namespace
2007-12-11 19:38:23 <3> linux-n04x(5049) [libycp] Bytecode.cc(readFile):1161
Caught invalid bytecode in '/usr/share/YaST2/modul
es/SlideShow.ybc'

It seems to show two different problems:

* Loading module 'Language' failed
Import.cc(import):97 No matching component found

- yast2-country has been split into two packages recently
(yast2-country and yast2-country-data). Language.ycp is newly in
yast2-country-data.
- Make sure you have yast2-country-data package installed.
- (Wrong dependencies in some YaST RPM?)
- If you have updated yast2-country to a new verson, Language.ycp
probably got deleted.

* Caught invalid bytecode in SlideShow.ybc

- Probably old yast2-packager (SlideShow is part of it). You need to
update that package too.
- Maybe caused be the very same mistake by wrong RPM dependencies.

You can still use 'zypper' to update your packages when YaST is broken :)

Bye
Lukas

PS: Adding yast-devel into Cc:

< Previous Next >
Follow Ups