Mailinglist Archive: yast-devel (129 mails)

< Previous Next >
[yast-devel] Mod-ui: HVStretch widget dropped
  • From: Katarina Machalkova <kmachalkova@xxxxxxx>
  • Date: Tue, 20 Nov 2007 16:23:23 +0100
  • Message-id: <200711201623.33410.kmachalkova@xxxxxxx>
Hola brave yast hackers!

I'd like to use this way to announce that with mod-ui transition, HVStretch
widget has been dropped and it should no longer be used. Should you still
need it in your module, consider using e.g. `Empty, or some combination of
`HStretch and `VStretch.

These modules seem to be affected:
ldap-client
certify

so please fix them accordingly, and if writing new code, please do not use
HVStretch any more, to prevent crashes and other ugly things with new mod-ui.

The documentation on UI widgets should be updated as well
Thanks

B.
--
\\\\\ Katarina Machalkova
\\\\\\\__o YaST developer
__\\\\\\\'/_ & hedgehog painter
< Previous Next >