Mailinglist Archive: yast-devel (132 mails)

< Previous Next >
Re: [yast-devel] openSUSE 11.0 - Splitting YaST packages - Call for help
  • From: Duncan Mac-Vicar Prett <dmacvicar@xxxxxxx>
  • Date: Mon, 29 Oct 2007 11:29:24 +0100
  • Message-id: <200710291129.24641.dmacvicar@xxxxxxx>

Is it possible that we create some kind of provides and requires extractor for
rpm just like there are for .so files, for perl, for mono, etc.

rpm -q --requires mono-winforms
mono(Mono.Posix) = 1.0.5000.0
mono(Mono.Posix) = 2.0.0.0
mono(System) = 1.0.5000.0
mono(System) = 2.0.0.0
mono(System.Configuration) = 2.0.0.0

So YaST modules could be scanned for provides and requires, and rpm
dependencies set automatically:

YaST(Storage) == 1.3

or something like that. That would prevent manual package requires that are
outdated, sometimes not needed, sometimes missing, etc?

Duncan
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
References