Mailinglist Archive: yast-commit (412 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-packager-master #5
  • From: jenkins@xxxxxxx
  • Date: Fri, 16 Oct 2015 10:46:36 +0200 (CEST)
  • Message-id: <-1512338591.26.1444985196913.JavaMail.jenkins@ci>
See <https://ci.suse.de/job/yast-packager-master/5/changes>

Changes:

[lslezak] repository manager - properly close the main window (bsc#950525)

------------------------------------------
[...truncated 1493 lines...]
[ 182s] # of expected passes 10
[ 182s] make -f /usr/share/YaST2/data/testsuite/Makefile.testsuite
RPMNAME=yast2-packager srcdir=. check
[ 182s] make[3]: Entering directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82/testsuite'
[ 182s]
[ 182s] Parse YCP
[ 182s] NOT RUNNING
[ 182s]
[ 182s] make[3]: Leaving directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82/testsuite'
[ 182s] make[2]: Leaving directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82/testsuite'
[ 182s] make[1]: Leaving directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82/testsuite'
[ 182s] make[1]: Entering directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82'
[ 182s] make[1]: Nothing to be done for 'check-am'.
[ 182s] make[1]: Leaving directory
'/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82'
[ 182s] ++ /usr/bin/find
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64//usr/share/applications/YaST2/
-name '*.desktop'
[ 182s] + for f in '$(/usr/bin/find
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64//usr/share/applications/YaST2/
-name '\''*.desktop'\'')'
[ 182s] + d=sw_single.desktop
[ 182s] + /usr/lib/rpm/suse_update_desktop_file.sh -d ycc_sw_single sw_single
[ 182s] + for f in '$(/usr/bin/find
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64//usr/share/applications/YaST2/
-name '\''*.desktop'\'')'
[ 182s] + d=sw_source.desktop
[ 182s] + /usr/lib/rpm/suse_update_desktop_file.sh -d ycc_sw_source sw_source
[ 183s] + for f in '$(/usr/bin/find
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64//usr/share/applications/YaST2/
-name '\''*.desktop'\'')'
[ 183s] + d=checkmedia.desktop
[ 183s] + /usr/lib/rpm/suse_update_desktop_file.sh -d ycc_checkmedia checkmedia
[ 183s] + /usr/lib/rpm/suse_update_desktop_file.sh yast2-packager
[ 183s] + /usr/lib/rpm/find-debuginfo.sh
/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82
[ 183s] + /usr/lib/rpm/brp-compress
[ 183s] + /usr/lib/rpm/brp-suse
[ 183s] calling /usr/lib/rpm/brp-suse.d/brp-05-permissions
[ 183s] setting / to root:root 0755. (wrong owner/group abuild:abuild)
[ 183s] setting /usr/ to root:root 0755. (wrong owner/group abuild:abuild)
[ 183s] calling /usr/lib/rpm/brp-suse.d/brp-15-strip-debug
[ 183s] calling /usr/lib/rpm/brp-suse.d/brp-20-check-la
[ 183s] calling /usr/lib/rpm/brp-suse.d/brp-25-symlink
[ 183s] calling /usr/lib/rpm/brp-suse.d/brp-30-desktop
[ 186s] WARNING: '/usr/lib/rpm/brp-desktop.data/suse-screensavers.menu' does
not exist
[ 186s] WARNING: '/usr/lib/rpm/brp-desktop.data/preferences-gnome.menu' does
not exist
[ 186s] WARNING: '/usr/lib/rpm/brp-desktop.data/applications-kmenuedit.menu'
does not exist
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-35-rpath
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-40-rootfs
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-45-tcl
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-50-check-python
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-55-boot-scripts
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-60-hook
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-65-lib64-linux
[ 187s] calling /usr/lib/rpm/brp-suse.d/brp-72-extract-appdata
[ 188s] Processing files: yast2-packager-3.1.82-1.x86_64
[ 188s] Provides: application() application(YaST2/checkmedia.desktop)
application(YaST2/sw_single.desktop) application(YaST2/sw_source.desktop)
application(yast2-packager.desktop)
mimehandler(application/x-redhat-package-manager)
mimehandler(application/x-rpm) yast2-packager = 3.1.82-1 yast2-packager(x86-64)
= 3.1.82-1
[ 188s] Requires(interp): /bin/sh /bin/sh
[ 188s] Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[ 188s] Requires(post): /bin/sh
[ 188s] Requires(postun): /bin/sh
[ 188s] Requires: /usr/bin/perl
[ 188s] Conflicts: yast2-core < 2.15.10 yast2-add-on < 2.15.15
[ 188s] Obsoletes: yast2-packager-webpin < 3.1.82
[ 188s] Processing files: yast2-packager-debugsource-3.1.82-1.x86_64
[ 188s] warning: Empty %files file
/home/abuild/rpmbuild/BUILD/yast2-packager-3.1.82/debugsources.list
[ 188s] Provides: yast2-packager-debugsource = 3.1.82-1
yast2-packager-debugsource(x86-64) = 3.1.82-1
[ 188s] Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
[ 188s] Processing files: yast2-packager-devel-doc-3.1.82-1.x86_64
[ 189s] Provides: yast2-packager-devel-doc = 3.1.82-1
yast2-packager-devel-doc(x86-64) = 3.1.82-1
[ 189s] Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[ 189s] Checking for unpackaged file(s): /usr/lib/rpm/check-files
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64
[ 190s] Wrote: /home/abuild/rpmbuild/SRPMS/yast2-packager-3.1.82-1.src.rpm
[ 192s] Wrote:
/home/abuild/rpmbuild/RPMS/x86_64/yast2-packager-3.1.82-1.x86_64.rpm
[ 192s] Wrote:
/home/abuild/rpmbuild/RPMS/x86_64/yast2-packager-debugsource-3.1.82-1.x86_64.rpm
[ 197s] Wrote:
/home/abuild/rpmbuild/RPMS/x86_64/yast2-packager-devel-doc-3.1.82-1.x86_64.rpm
[ 197s] Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.nS5c4W
[ 197s] + umask 022
[ 197s] + cd /home/abuild/rpmbuild/BUILD
[ 197s] + cd yast2-packager-3.1.82
[ 197s] + /usr/bin/rm -rf
/home/abuild/rpmbuild/BUILDROOT/yast2-packager-3.1.82-1.x86_64
[ 197s] + exit 0
[ 197s] ... checking for files with abuild user/group
[ 197s] ... running 00-check-install-rpms
[ 197s] ... installing all built rpms
[ 197s] Preparing packages...
[ 197s] yast2-packager-3.1.82-1.x86_64
[ 198s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/gnome-defaults.list: No such file or directory
[ 198s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/xfce-defaults.list: No such file or directory
[ 198s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/lxde-defaults.list: No such file or directory
[ 198s] yast2-packager-devel-doc-3.1.82-1.x86_64
[ 198s] yast2-packager-debugsource-3.1.82-1.x86_64
[ 198s] ... running 01-check-debuginfo
[ 198s] ... testing for empty debuginfo packages
[ 198s] !
[ 198s] !
/var/tmp/build-root-SLE-12-SP1/.build.packages/RPMS/x86_64/yast2-packager-debugsource-3.1.82-1.x86_64.rpm:
empty debuginfo/debugsource package, deleting
[ 198s] !
[ 198s] ... running 02-check-gcc-output
[ 198s] ... testing for serious compiler warnings
[ 198s] (using /usr/lib/build/checks-data/check_gcc_output)
[ 198s] (using /var/tmp/build-root-SLE-12-SP1/.build.log)
[ 198s] ... running 03-check-binary-kernel-log
[ 198s] ... running 04-check-filelist
[ 198s] ... checking filelist
[ 199s] ... running 05-check-invalid-requires
[ 199s] ... running 06-check-installtest
[ 199s] ... testing for pre/postinstall scripts that are not idempotent
[ 200s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/gnome-defaults.list: No such file or directory
[ 200s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/xfce-defaults.list: No such file or directory
[ 200s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/lxde-defaults.list: No such file or directory
[ 200s] ... running 08-check-permissions
[ 200s] ... testing for modified permissions
[ 201s] ... running 09-check-packaged-twice
[ 201s] ... running 10-check-lanana
[ 202s] ... running 12-check-libtool-deps
[ 202s] ... testing devel dependencies required by libtool .la files
[ 202s] (can be skipped by "skip-check-libtool-deps" anywhere in spec)
[ 202s] ... running 13-check-invalid-provides
[ 202s] ... running 14-check-gconf-scriptlets
[ 202s] ... testing GConf scriptlet presence
[ 202s] ... running 72-translate-appdata
[ 202s] ... running 80-check-malware-scan-clamav
[ 263s] clamav: negative malware scan result.
[ 263s] unpacking
/.build.packages/RPMS/x86_64/yast2-packager-3.1.82-1.x86_64.rpm
[ 263s] unpacking
/.build.packages/RPMS/x86_64/yast2-packager-devel-doc-3.1.82-1.x86_64.rpm
[ 263s] unpacking /.build.packages/SRPMS/yast2-packager-3.1.82-1.src.rpm
[ 263s] unpacking
/.build.packages/BUILD/yast2-packager-3.1.82/testsuite/spkg/gnuchess.rpm
[ 263s] clamscan -ir /usr/src/packages/BUILD/scan:
[ 263s] LibClamAV Warning: **************************************************
[ 263s] LibClamAV Warning: *** The virus database is older than 7 days! ***
[ 263s] LibClamAV Warning: *** Please update it as soon as possible. ***
[ 263s] LibClamAV Warning: **************************************************
[ 263s]
[ 263s] ----------- SCAN SUMMARY -----------
[ 263s] Known viruses: 3952105
[ 263s] Engine version: 0.98.4
[ 263s] Scanned directories: 37
[ 263s] Scanned files: 107
[ 263s] Infected files: 0
[ 263s] Data scanned: 12.18 MB
[ 263s] Data read: 7.08 MB (ratio 1.72:1)
[ 263s] Time: 59.417 sec (0 m 59 s)
[ 263s] test passed.
[ 263s] ... running 99-check-remove-rpms
[ 263s] ... removing all built rpms
[ 263s] (order: reverse yast2-packager yast2-packager-devel-doc)
[ 263s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/gnome-defaults.list: No such file or directory
[ 263s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/xfce-defaults.list: No such file or directory
[ 263s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/lxde-defaults.list: No such file or directory
[ 264s]
[ 264s] RPMLINT report:
[ 264s] ===============
[ 271s] yast2-packager.x86_64: W: obsolete-not-provided yast2-packager-webpin
[ 271s] If a package is obsoleted by a compatible replacement, the obsoleted
package
[ 271s] should also be provided in order to not cause unnecessary dependency
breakage.
[ 271s] If the obsoleting package is not a compatible replacement for the old
one,
[ 271s] leave out the Provides.
[ 271s]
[ 271s] yast2-packager.x86_64: W: no-binary
[ 271s] The package should be of the noarch architecture because it doesn't
contain
[ 271s] any binaries.
[ 271s]
[ 271s] yast2-packager-devel-doc.x86_64: W: files-duplicate
/usr/share/doc/packages/yast2-packager/autodocs/index.html
/usr/share/doc/packages/yast2-packager/autodocs/_index.html
[ 271s] yast2-packager.src:136: W: files-attr-not-set
[ 271s] A file or a directory entry in a %files section does not have
attributes set
[ 271s] which may result in unexpected file permissions and thus security
issues in
[ 271s] the resulting binary package depending on the build environment and
rpmbuild
[ 271s] version (typically < 4.4). Add default attributes using %defattr
before it in
[ 271s] the %files section, or use per entry %attr's.
[ 271s]
[ 271s] yast2-packager.x86_64: W: explicit-lib-dependency libyui_pkg
[ 271s] You must let rpm find the library dependencies by itself. Do not put
unneeded
[ 271s] explicit Requires: tags.
[ 271s]
[ 271s] yast2-packager.x86_64: W: desktopfile-without-binary
/usr/share/applications/YaST2/sw_single.desktop xdg-su
[ 271s] yast2-packager.x86_64: W: desktopfile-without-binary
/usr/share/applications/yast2-packager.desktop xdg-su
[ 271s] yast2-packager.x86_64: W: desktopfile-without-binary
/usr/share/applications/YaST2/sw_source.desktop xdg-su
[ 271s] yast2-packager.x86_64: W: desktopfile-without-binary
/usr/share/applications/YaST2/checkmedia.desktop /sbin/yast2
[ 271s] the .desktop file is for a file not present in the package. You should
check
[ 271s] the requires or see if this is not a error
[ 271s]
[ 271s] 3 packages and 0 specfiles checked; 0 errors, 9 warnings.
[ 271s]
[ 271s]
[ 271s] vm-yast-ci-worker2 finished "build yast2-packager.spec" at Fri Oct 16
08:43:32 UTC 2015.
[ 271s]
Building yast2-packager.spec for SLE-12-SP1/x86_64
Getting buildinfo from server and store to
<https://ci.suse.de/job/yast-packager-master/ws/Devel>:YaST:Head/yast2-packager/.osc/_buildinfo-SLE-12-SP1-x86_64.xml
Getting buildconfig from server and store to
<https://ci.suse.de/job/yast-packager-master/ws/Devel>:YaST:Head/yast2-packager/.osc/_buildconfig-SLE-12-SP1-x86_64
Updating cache of required packages
6.3% cache miss. 192/205 dependencies cached.

1/13 (SUSE:SLE-12-SP1:GA) kernel-obs-build-3.12.49-3.1.x86_64.rpm
2/13 (Devel:YaST:Head) yast2-devtools-3.1.38-2.1.noarch.rpm
3/13 (Devel:YaST:Head) yast2-storage-3.1.69-1.39.x86_64.rpm
4/13 (Devel:YaST:Head) yast2-3.1.152-2.3.x86_64.rpm
5/13 (Devel:YaST:Head) yast2-core-3.1.17-11.68.x86_64.rpm
6/13 (Devel:YaST:Head) yast2-buildtools-3.1.38-2.1.noarch.rpm
7/13 (SUSE:SLE-12-SP1:GA) libzypp-15.19.2-2.4.x86_64.rpm
8/13 (SUSE:SLE-12-SP1:GA) hwinfo-21.23-1.2.x86_64.rpm
9/13 (SUSE:SLE-12-SP1:GA) libudev-mini1-210-78.2.x86_64.rpm
10/13 (SUSE:SLE-12-SP1:GA) udev-mini-210-78.2.x86_64.rpm
11/13 (SUSE:SLE-12-SP1:GA) suse-module-tools-12.3-19.1.x86_64.rpm
12/13 (Devel:YaST:Head) yast2-theme-SLE-3.1.34-5.1.noarch.rpm
13/13 (SUSE:SLE-12-SP1:GA) systemd-mini-210-78.2.x86_64.rpm
Skipping verification of package signatures
Writing build configuration
Running build

/var/tmp/build-root-SLE-12-SP1/home/abuild/rpmbuild/SRPMS/yast2-packager-3.1.82-1.src.rpm

/var/tmp/build-root-SLE-12-SP1/home/abuild/rpmbuild/RPMS/x86_64/yast2-packager-3.1.82-1.x86_64.rpm
/var/tmp/build-root-SLE-12-SP1/home/abuild/rpmbuild/RPMS/x86_64/yast2-packager-devel-doc-3.1.82-1.x86_64.rpm
rm -rf Devel:YaST:Head
osc -A 'https://api.suse.de/' --traceback --verbose checkout 'Devel:YaST:Head'
yast2-packager
cleaning
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/osc/babysitter.py", line 61, in run
return prg.main(argv)
File "/usr/lib/python2.7/site-packages/osc/cmdln.py", line 343, in main
return self.cmd(args)
File "/usr/lib/python2.7/site-packages/osc/cmdln.py", line 366, in cmd
retval = self.onecmd(argv)
File "/usr/lib/python2.7/site-packages/osc/cmdln.py", line 500, in onecmd
return self._dispatch_cmd(handler, argv)
File "/usr/lib/python2.7/site-packages/osc/cmdln.py", line 1230, in
_dispatch_cmd
return handler(argv[0], opts, *args)
File "/usr/lib/python2.7/site-packages/osc/commandline.py", line 4073, in
do_checkout
meta=opts.meta, outdir=opts.output_dir)
File "/usr/lib/python2.7/site-packages/osc/core.py", line 4672, in
checkout_package
show_package_meta(apiurl, project, package, meta)
File "/usr/lib/python2.7/site-packages/osc/core.py", line 3349, in
show_package_meta
f = http_GET(url)
File "/usr/lib/python2.7/site-packages/osc/core.py", line 3220, in http_GET
def http_GET(*args, **kwargs): return http_request('GET', *args,
**kwargs)
File "/usr/lib/python2.7/site-packages/osc/core.py", line 3209, in
http_request
fd = urlopen(req, data=data)
File "/usr/lib64/python2.7/urllib2.py", line 127, in urlopen
return _opener.open(url, data, timeout)
File "/usr/lib64/python2.7/urllib2.py", line 404, in open
response = self._open(req, data)
File "/usr/lib64/python2.7/urllib2.py", line 422, in _open
'_open', req)
File "/usr/lib64/python2.7/urllib2.py", line 382, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/site-packages/osc/oscssl.py", line 226, in https_open
raise M2Crypto.m2urllib2.URLError(err)
URLError: <urlopen error [Errno 110] Connection timed out:
'https://api.suse.de/source/Devel:YaST:Head/yast2-packager/_meta'>
Failed to reach a server:
[Errno 110] Connection timed out:
'https://api.suse.de/source/Devel:YaST:Head/yast2-packager/_meta'
makeurl: https://api.suse.de ['source', 'Devel:YaST:Head', 'yast2-packager',
'_meta'] {}
rm -rf Devel:YaST:Head
rake aborted!
Command failed with status (1): [osc -A 'https://api.suse.de/' --traceback ...]

Tasks: TOP => osc:sr => osc:commit
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure

< Previous Next >
This Thread
Follow Ups