Mailinglist Archive: yast-commit (513 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-auth-client-master #52
  • From: hudson@xxxxxxx
  • Date: Fri, 17 Apr 2015 09:46:54 +0200 (CEST)
  • Message-id: <2045259872.131.1429256814482.JavaMail.jenkins@river>
See <http://river.suse.de/job/yast-auth-client-master/52/changes>

Changes:

[lslezak] Fixed typo in CONTRIBUTING.md

------------------------------------------
[...truncated 204 lines...]
[ 1s] Using BUILD_ARCH=x86_64:i686:i586:i486:i386
[ 1s]
[ 1s]
[ 1s] vm-zofie-slms started "build yast2-auth-client.spec" at Fri Apr 17
07:45:52 UTC 2015.
[ 1s]
[ 1s]
[ 1s] processing recipe
<http://river.suse.de/job/yast-auth-client-master/ws/Devel>:YaST:Head/yast2-auth-client/yast2-auth-client.spec
...
[ 1s] running changelog2spec --target rpm --file
<http://river.suse.de/job/yast-auth-client-master/ws/Devel>:YaST:Head/yast2-auth-client/yast2-auth-client.spec
[ 1s] changes file not incremental: Thu Dec 4 09:49:20 UTC 2014 -
jreidinger@xxxxxxxx
[ 1s] init_buildsystem --configdir /usr/lib/build/configs --cachedir
/var/cache/build --rpmlist /tmp/rpmlist.7TBWiC
<http://river.suse.de/job/yast-auth-client-master/ws/Devel>:YaST:Head/yast2-auth-client/yast2-auth-client.spec
...
[ 3s] reordering...cycle: libcrack2 -> cracklib
[ 3s] breaking dependency libcrack2 -> cracklib
[ 3s] cycle: ruby2.1 -> ruby-common
[ 3s] breaking dependency ruby-common -> ruby2.1
[ 3s] cycle: ruby2.1 -> ruby-common -> ruby2.1-rubygem-gem2rpm
[ 3s] breaking dependency ruby-common -> ruby2.1-rubygem-gem2rpm
[ 3s] cycle: libudev-mini1 -> udev-mini
[ 3s] breaking dependency udev-mini -> libudev-mini1
[ 3s] cycle: sysconfig-netconfig -> sysconfig
[ 3s] breaking dependency sysconfig-netconfig -> sysconfig
[ 3s] done
[ 5s] deleting keyutils
[ 5s] deleting libevent-2_0-5
[ 5s] deleting libtirpc1
[ 5s] deleting netcfg
[ 5s] warning: /etc/hosts saved as /etc/hosts.rpmsave
[ 5s] deleting nfs-client
[ 6s] deleting nfsidmap
[ 6s] deleting rpcbind
[ 6s] deleting yast2-nfs-client-debugsource
[ 7s] [1/217] [2/217] [3/217] [4/217] [5/217] [6/217] [7/217] [8/217]
[9/217] [10/217] [11/217] [12/217] cumulate libaio1-0.3.109-17.15
[ 7s] [13/217] [14/217] [15/217] [16/217] [17/217] [18/217] [19/217]
[20/217] [21/217] [22/217] [23/217] cumulate libfipscheck1-1.2.0-9.3
[ 7s] [24/217] [25/217] [26/217] [27/217] [28/217] [29/217] [30/217]
[31/217] [32/217] [33/217] [34/217] [35/217] [36/217] [37/217] [38/217]
[39/217] [40/217] [41/217] [42/217] [43/217] [44/217] [45/217] [46/217]
[47/217] [48/217] [49/217] cumulate lsscsi-0.27-4.17
[ 8s] [50/217] [51/217] [52/217] [53/217] [54/217] [55/217] [56/217]
[57/217] [58/217] [59/217] [60/217] [61/217] [62/217] [63/217] [64/217]
[65/217] [66/217] [67/217] [68/217] [69/217] [70/217] [71/217] [72/217]
[73/217] [74/217] [75/217] [76/217] cumulate doxygen-1.8.6-1.20
[ 8s] [77/217] [78/217] [79/217] [80/217] [81/217] [82/217] [83/217]
deleting unwanted libssh2-1-1.4.3-8.60
[ 8s] cumulate libssh2-1-1.4.3-11.1
[ 8s] [84/217] [85/217] [86/217] [87/217] [88/217] [89/217] [90/217]
[91/217] [92/217] [93/217] [94/217] [95/217] [96/217] [97/217] [98/217]
[99/217] [100/217] [101/217] [102/217] [103/217] [104/217] [105/217] cumulate
unzip-6.00-32.1
[ 8s] [106/217] [107/217] [108/217] [109/217] deleting unwanted
yast2-core-3.1.17-3.1
[ 9s] cumulate yast2-core-3.1.17-4.2
[ 9s] [110/217] [111/217] [112/217] [113/217] [114/217] [115/217] [116/217]
[117/217] [118/217] [119/217] [120/217] [121/217] [122/217] [123/217] [124/217]
cumulate yast2-xml-3.1.1-18.1
[ 9s] [125/217] deleting unwanted yast2-ycp-ui-bindings-3.1.7-30.1
[ 9s] cumulate yast2-ycp-ui-bindings-3.1.7-32.1
[ 9s] [126/217] [127/217] [128/217] [129/217] [130/217] [131/217] [132/217]
[133/217] [134/217] [135/217] [136/217] deleting unwanted
yast2-perl-bindings-3.1.2-22.1
[ 9s] cumulate yast2-perl-bindings-3.1.2-24.1
[ 9s] [137/217] cumulate mdadm-3.3.1-5.28
[ 9s] [138/217] [139/217] [140/217] [141/217] [142/217] [143/217] [144/217]
[145/217] [146/217] [147/217] [148/217] [149/217] [150/217] [151/217] [152/217]
cumulate curl-7.37.0-9.1
[ 10s] [153/217] [154/217] [155/217] [156/217] [157/217] [158/217] [159/217]
[160/217] [161/217] cumulate pam-config-0.88-1.1
[ 10s] [162/217] [163/217] [164/217] [165/217] [166/217] [167/217] [168/217]
[169/217] [170/217] [171/217] [172/217] [173/217] [174/217] [175/217] [176/217]
[177/217] [178/217] [179/217] [180/217] [181/217] [182/217] [183/217] [184/217]
[185/217] cumulate ruby2.1-rubygem-ruby-dbus-0.9.3-3.6
[ 10s] [186/217] [187/217] [188/217] [189/217] [190/217] deleting unwanted
yast2-ruby-bindings-3.1.31-1.1
[ 12s] cumulate yast2-ruby-bindings-3.1.31-2.1
[ 12s] [191/217] deleting unwanted yast2-buildtools-3.1.30-3.1
[ 12s] cumulate yast2-buildtools-3.1.30-6.1
[ 12s] [192/217] [193/217] cumulate yast2-country-data-3.1.20-44.2
[ 12s] [194/217] [195/217] cumulate kpartx-0.5.0-33.1
[ 12s] [196/217] [197/217] deleting unwanted yast2-devtools-3.1.30-3.1
[ 12s] cumulate yast2-devtools-3.1.30-6.1
[ 12s] [198/217] deleting unwanted yast2-testsuite-3.1.2-19.3
[ 12s] cumulate yast2-testsuite-3.1.2-20.2
[ 12s] [199/217] cumulate libcryptsetup4-1.6.4-2.10
[ 12s] [200/217] cumulate libparted0-3.1-13.1
[ 12s] [201/217] cumulate lvm2-2.02.98-48.8
[ 12s] [202/217] deleting unwanted yast2-hardware-detection-3.1.7-4.1
[ 12s] cumulate yast2-hardware-detection-3.1.7-6.1
[ 12s] [203/217] cumulate yast2-transfer-3.1.1-26.1
[ 12s] [204/217] cumulate cryptsetup-1.6.4-2.10
[ 12s] [205/217] cumulate parted-3.1-13.1
[ 12s] [206/217] cumulate dmraid-1.0.0.rc16-31.5
[ 12s] [207/217] cumulate multipath-tools-0.5.0-33.1
[ 12s] [208/217] [209/217] [210/217] cumulate libstorage6-2.25.20-5.2
[ 12s] [211/217] cumulate libstorage-ruby-2.25.20-5.2
[ 12s] [212/217] deleting unwanted yast2-pkg-bindings-3.1.23-1.1
[ 12s] cumulate yast2-pkg-bindings-3.1.23-3.1
[ 12s] [213/217] deleting unwanted yast2-3.1.121-10.2
[ 13s] cumulate yast2-3.1.121-13.1
[ 13s] [214/217] cumulate yast2-pam-3.1.1-23.1
[ 13s] [215/217] cumulate yast2-packager-3.1.66-6.1
[ 13s] [216/217] cumulate yast2-storage-3.1.54-5.1
[ 13s] [217/217] cumulate yast2-network-3.1.113-10.1
[ 13s] now installing cumulated packages
[ 13s] Preparing...
########################################
[ 13s] Updating / installing...
[ 13s] yast2-core-3.1.17-4.2
########################################
[ 13s] yast2-ycp-ui-bindings-3.1.7-32.1
########################################
[ 13s] yast2-ruby-bindings-3.1.31-2.1
########################################
[ 13s] yast2-country-data-3.1.20-44.2
########################################
[ 13s] yast2-xml-3.1.1-18.1
########################################
[ 14s] yast2-pkg-bindings-3.1.23-3.1
########################################
[ 14s] kpartx-0.5.0-33.1
########################################
[ 14s] libfipscheck1-1.2.0-9.3
########################################
[ 14s] libcryptsetup4-1.6.4-2.10
########################################
[ 14s] cryptsetup-1.6.4-2.10
########################################
[ 15s] dmraid-1.0.0.rc16-31.5
########################################
[ 15s] yast2-hardware-detection-3.1.7-6.1
########################################
[ 15s] yast2-perl-bindings-3.1.2-24.1
########################################
[ 15s] yast2-3.1.121-13.1
########################################
[ 15s] Updating /etc/sysconfig/yast2...
[ 20s] lvm2-2.02.98-48.8
########################################
[ 20s] libparted0-3.1-13.1
########################################
[ 20s] parted-3.1-13.1
########################################
[ 20s] yast2-buildtools-3.1.30-6.1
########################################
[ 21s] ruby2.1-rubygem-ruby-dbus-0.9.3-3.6
########################################
[ 21s] pam-config-0.88-1.1
########################################
[ 21s] *** write_config (account, /etc/pam.d/common-account-pc, ...)
[ 21s] **** write config for pam_access.so (account, disabled)
[ 21s] **** write config for pam_unix2.so (account, disabled)
[ 21s] **** write config for pam_unix.so (account, enabled)
[ 21s] **** write config for pam_krb5.so (account, disabled)
[ 21s] **** write config for pam_localuser.so (account, disabled)
[ 21s] **** write config for pam_sss.so (account, disabled)
[ 21s] **** write config for pam_ldap.so (account, disabled)
[ 21s] **** write config for pam_nam.so (account, disabled)
[ 21s] **** write config for pam_winbind.so (account, disabled)
[ 21s] **** write config for pam_time.so (account, disabled)
[ 21s] *** write_config (auth, /etc/pam.d/common-auth-pc, ...)
[ 21s] **** write config for pam_env.so (auth, enabled)
[ 21s] **** write config for pam_group.so (auth, disabled)
[ 21s] **** write config for pam_pkcs11.so (auth, disabled)
[ 21s] **** write config for pam_fp.so (auth, disabled)
[ 21s] **** write config for pam_fprint.so (auth, disabled)
[ 21s] **** write config for pam_fprintd.so (auth, disabled)
[ 21s] **** write config for pam_thinkfinger.so (auth, disabled)
[ 21s] **** write config for pam_gnome_keyring.so (auth, disabled)
[ 21s] **** write config for pam_ssh.so (auth, disabled)
[ 21s] **** write config for pam_unix2.so (auth, disabled)
[ 21s] **** write config for pam_unix.so (auth, enabled)
[ 21s] **** write config for pam_ecryptfs.so (auth, disabled)
[ 21s] **** write config for pam_krb5.so (auth, disabled)
[ 21s] **** write config for pam_sss.so (auth, disabled)
[ 21s] **** write config for pam_ldap.so (auth, disabled)
[ 21s] **** write config for pam_nam.so (auth, disabled)
[ 21s] **** write config for pam_winbind.so (auth, disabled)
[ 21s] *** write_config (password, /etc/pam.d/common-password-pc, ...)
[ 21s] **** write config for pam_winbind.so (password, disabled)
[ 21s] **** write config for pam_pwcheck.so (password, disabled)
[ 21s] **** write config for pam_passwdqc.so (password, disabled)
[ 21s] **** write config for pam_cracklib.so (password, enabled)
[ 21s] **** write config for pam_pwhistory.so (password, disabled)
[ 21s] **** write config for pam_gnome_keyring.so (password, disabled)
[ 21s] **** write config for pam_ecryptfs.so (password, disabled)
[ 21s] **** write config for pam_unix2.so (password, disabled)
[ 21s] **** write config for pam_unix.so (password, enabled)
[ 21s] **** write config for pam_make.so (password, disabled)
[ 21s] **** write config for pam_exec.so (password, disabled)
[ 21s] **** write config for pam_krb5.so (password, disabled)
[ 21s] **** write config for pam_sss.so (password, disabled)
[ 21s] **** write config for pam_ldap.so (password, disabled)
[ 21s] **** write config for pam_nam.so (password, disabled)
[ 21s] *** write_config (session, /etc/pam.d/common-session-pc, ...)
[ 21s] **** write config for pam_selinux.so (session, disabled)
[ 21s] **** write config for pam_mkhomedir.so (session, disabled)
[ 21s] **** write config for pam_limits.so (session, enabled)
[ 21s] **** write config for pam_unix2.so (session, disabled)
[ 21s] **** write config for pam_unix.so (session, enabled)
[ 21s] **** write config for pam_apparmor.so (session, disabled)
[ 21s] **** write config for pam_krb5.so (session, disabled)
[ 21s] **** write config for pam_sss.so (session, disabled)
[ 21s] **** write config for pam_ldap.so (session, disabled)
[ 21s] **** write config for pam_winbind.so (session, disabled)
[ 21s] **** write config for pam_nam.so (session, disabled)
[ 21s] **** write config for pam_umask.so (session, enabled)
[ 21s] **** write config for pam_ssh.so (session, disabled)
[ 21s] **** write config for pam_systemd.so (session, disabled)
[ 21s] **** write config for pam_selinux.so (session, disabled)
[ 21s] **** write config for pam_gnome_keyring.so (session, disabled)
[ 21s] **** write config for pam_exec.so (session, disabled)
[ 21s] **** write config for pam_ecryptfs.so (session, disabled)
[ 21s] **** write config for pam_env.so (session, enabled)
[ 21s] curl-7.37.0-9.1
########################################
[ 21s] yast2-transfer-3.1.1-26.1
########################################
[ 21s] mdadm-3.3.1-5.28
########################################
[ 21s] Updating /etc/sysconfig/mdadm...
[ 24s] unzip-6.00-32.1
########################################
[ 24s] update-alternatives: using /usr/bin/unzip-plain to provide
/usr/bin/unzip (unzip) in auto mode
[ 24s] update-alternatives: using /usr/bin/funzip-plain to provide
/usr/bin/funzip (funzip) in auto mode
[ 24s] update-alternatives: using /usr/bin/unzipsfx-plain to provide
/usr/bin/unzipsfx (unzipsfx) in auto mode
[ 24s] update-alternatives: using /usr/bin/zipgrep-plain to provide
/usr/bin/zipgrep (zipgrep) in auto mode
[ 24s] yast2-packager-3.1.66-6.1
########################################
[ 25s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/gnome-defaults.list: No such file or directory
[ 25s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/xfce-defaults.list: No such file or directory
[ 25s] /usr/bin/suse-update-mime-defaults: line 28:
/var/cache/gio-2.0/lxde-defaults.list: No such file or directory
[ 25s] lsscsi-0.27-4.17
########################################
[ 25s] libaio1-0.3.109-17.15
########################################
[ 25s] multipath-tools-0.5.0-33.1
########################################
[ 25s] libstorage6-2.25.20-5.2
########################################
[ 25s] Updating /etc/sysconfig/storage...
[ 27s] libstorage-ruby-2.25.20-5.2
########################################
[ 28s] yast2-storage-3.1.54-5.1
########################################
[ 28s] Updating /etc/sysconfig/storage...
[ 28s] yast2-network-3.1.113-10.1
########################################
[ 28s] yast2-pam-3.1.1-23.1
########################################
[ 29s] yast2-devtools-3.1.30-6.1
########################################
[ 29s] yast2-testsuite-3.1.2-20.2
########################################
[ 29s] libssh2-1-1.4.3-11.1
########################################
[ 29s] doxygen-1.8.6-1.20
########################################
[ 29s] Please run mkinitrd as soon as your system is complete.
[ 29s] Updating /etc/sysconfig/dmraid...
[ 33s] removing nis flags from
/var/tmp/build-root-SLE-12-SP1/etc/nsswitch.conf...
[ 33s] now finalizing build dir...
[ 34s] -----------------------------------------------------------------
[ 34s] I have the following modifications for yast2-auth-client.spec:
[ 34s] 21c21
[ 34s] < Release: 0
[ 34s] ---
[ 34s] > Release: 1
[ 34s] 71a72
[ 34s] > %changelog
[ 34s] -----------------------------------------------------------------
[ 34s] ----- building yast2-auth-client.spec (user abuild)
[ 34s] -----------------------------------------------------------------
[ 34s] -----------------------------------------------------------------
[ 34s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
--define '_build_create_debug 1'
/home/abuild/rpmbuild/SOURCES/yast2-auth-client.spec
[ 35s] error: %changelog not in descending chronological order
Building yast2-auth-client.spec for SLE-12-SP1/x86_64
Getting buildinfo from server and store to
<http://river.suse.de/job/yast-auth-client-master/ws/Devel>:YaST:Head/yast2-auth-client/.osc/_buildinfo-SLE-12-SP1-x86_64.xml
Getting buildconfig from server and store to
<http://river.suse.de/job/yast-auth-client-master/ws/Devel>:YaST:Head/yast2-auth-client/.osc/_buildconfig-SLE-12-SP1-x86_64
Updating cache of required packages
8.3% cache miss. 199/217 dependencies cached.

1/18 (Devel:YaST:Head) yast2-3.1.121-13.1.x86_64.rpm
2/18 (Devel:YaST:Head) yast2-pam-3.1.1-23.1.noarch.rpm
3/18 (Devel:YaST:Head) yast2-testsuite-3.1.2-20.2.noarch.rpm
4/18 (Devel:YaST:Head) yast2-network-3.1.113-10.1.x86_64.rpm
5/18 (Devel:YaST:Head) yast2-devtools-3.1.30-6.1.noarch.rpm
6/18 (Devel:YaST:Head) yast2-perl-bindings-3.1.2-24.1.x86_64.rpm
7/18 (Devel:YaST:Head) yast2-hardware-detection-3.1.7-6.1.x86_64.rpm
8/18 (Devel:YaST:Head) yast2-ruby-bindings-3.1.31-2.1.x86_64.rpm
9/18 (Devel:YaST:Head) yast2-core-3.1.17-4.2.x86_64.rpm
10/18 (Devel:YaST:Head) yast2-pkg-bindings-3.1.23-3.1.x86_64.rpm
11/18 (Devel:YaST:Head) yast2-ycp-ui-bindings-3.1.7-32.1.x86_64.rpm
12/18 (Devel:YaST:Head) yast2-country-data-3.1.20-44.2.x86_64.rpm
13/18 (Devel:YaST:Head) yast2-packager-3.1.66-6.1.x86_64.rpm
14/18 (Devel:YaST:Head) yast2-storage-3.1.54-5.1.x86_64.rpm
15/18 (Devel:YaST:Head) yast2-buildtools-3.1.30-6.1.noarch.rpm
16/18 (Devel:YaST:Head) yast2-transfer-3.1.1-26.1.x86_64.rpm
17/18 (Devel:YaST:Head) yast2-xml-3.1.1-18.1.x86_64.rpm
18/18 (SUSE:SLE-12:Update) libssh2-1-1.4.3-11.1.x86_64.rpm
Skipping verification of package signatures
Writing build configuration
Running build

The buildroot was: /var/tmp/build-root-SLE-12-SP1
rm -rf Devel:YaST:Head
rake aborted!
Command failed with status (1): [yes | osc build --no-verify --release=1 --...]

Tasks: TOP => osc:sr => osc:commit => osc:build
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure

< Previous Next >
Follow Ups
References