Mailinglist Archive: yast-commit (126 mails)

< Previous Next >
[yast-commit] r67652 - in /trunk: cim/ dbus-server/ gtk/ hardware-detection/ ldap/ ncurses-pkg/ ncurses/ openwsman-yast/ packager/ perl-bindings/ pkg-bindings/ profile-manager/ python-bindings/ qt-pkg/ qt/ ruby-...
Author: aschnell
Date: Fri Mar 16 16:10:32 2012
New Revision: 67652

URL: http://svn.opensuse.org/viewcvs/yast?rev=67652&view=rev
Log:
- removed libxcrypt-devel from buildrequires

Modified:
trunk/cim/yast2-cim.spec.in
trunk/dbus-server/yast2-dbus-server.spec.in
trunk/gtk/yast2-gtk.spec.in
trunk/hardware-detection/yast2-hardware-detection.spec.in
trunk/ldap/yast2-ldap.spec.in
trunk/ncurses-pkg/yast2-ncurses-pkg.spec.in
trunk/ncurses/yast2-ncurses.spec.in
trunk/openwsman-yast/openwsman-yast.spec.in
trunk/packager/yast2-packager.spec.in
trunk/perl-bindings/yast2-perl-bindings.spec.in
trunk/pkg-bindings/yast2-pkg-bindings-devel-doc.spec.in
trunk/pkg-bindings/yast2-pkg-bindings.spec.in
trunk/profile-manager/yast2-profile-manager.spec.in
trunk/python-bindings/yast2-python-bindings.spec.in
trunk/qt-pkg/yast2-qt-pkg.spec.in
trunk/qt/yast2-qt.spec.in
trunk/ruby-bindings/yast2-ruby-bindings.spec.in
trunk/slp/yast2-slp.spec.in
trunk/storage/yast2-storage.spec.in
trunk/transfer/yast2-transfer.spec.in
trunk/ycp-ui-bindings/yast2-ycp-ui-bindings.spec.in

Modified: trunk/cim/yast2-cim.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/cim/yast2-cim.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/cim/yast2-cim.spec.in (original)
+++ trunk/cim/yast2-cim.spec.in Fri Mar 16 16:10:32 2012
@@ -2,7 +2,7 @@


@HEADER@
-BuildRequires: gcc-c++ libxcrypt-devel openssl-devel openwbem-devel
yast2-core-devel yast2-devtools
+BuildRequires: gcc-c++ openssl-devel openwbem-devel yast2-core-devel
yast2-devtools
Summary: CIM API for YaST modules

%description

Modified: trunk/dbus-server/yast2-dbus-server.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/dbus-server/yast2-dbus-server.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/dbus-server/yast2-dbus-server.spec.in (original)
+++ trunk/dbus-server/yast2-dbus-server.spec.in Fri Mar 16 16:10:32 2012
@@ -19,7 +19,7 @@
BuildRequires: sgml-skel

# for SCR DBus service
-BuildRequires: dbus-1-devel dbus-1-x11 polkit-devel libxcrypt-devel
+BuildRequires: dbus-1-devel dbus-1-x11 polkit-devel
# its tests
BuildRequires: dbus-1-python python-devel
# its tests

Modified: trunk/gtk/yast2-gtk.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/gtk/yast2-gtk.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/gtk/yast2-gtk.spec.in (original)
+++ trunk/gtk/yast2-gtk.spec.in Fri Mar 16 16:10:32 2012
@@ -7,7 +7,7 @@
Group: System/YaST
License: GPL-2.0 or GPL-3.0
BuildRequires: cmake
-BuildRequires: gcc-c++ blocxx-devel libxcrypt-devel
+BuildRequires: gcc-c++ blocxx-devel
BuildRequires: gtk3-devel
BuildRequires: gdk-pixbuf-devel
BuildRequires: yast2-devtools >= 2.16.3

Modified: trunk/hardware-detection/yast2-hardware-detection.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/hardware-detection/yast2-hardware-detection.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/hardware-detection/yast2-hardware-detection.spec.in (original)
+++ trunk/hardware-detection/yast2-hardware-detection.spec.in Fri Mar 16
16:10:32 2012
@@ -16,8 +16,6 @@
BuildRequires: yast2-core-devel
# liby2.la
BuildRequires: blocxx-devel
-# libycp.la wants libxcrypt.la
-BuildRequires: libxcrypt-devel
# libycp.la
BuildRequires: openssl-devel
# da library

Modified: trunk/ldap/yast2-ldap.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/ldap/yast2-ldap.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/ldap/yast2-ldap.spec.in (original)
+++ trunk/ldap/yast2-ldap.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0
-BuildRequires: gcc-c++ libldapcpp-devel libxcrypt-devel yast2-devtools doxygen
yast2-core-devel yast2 libtool
+BuildRequires: gcc-c++ libldapcpp-devel yast2-devtools doxygen
yast2-core-devel yast2 libtool
Summary: YaST2 - LDAP Agent
Requires: ldapcpplib yast2


Modified: trunk/ncurses-pkg/yast2-ncurses-pkg.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/ncurses-pkg/yast2-ncurses-pkg.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/ncurses-pkg/yast2-ncurses-pkg.spec.in (original)
+++ trunk/ncurses-pkg/yast2-ncurses-pkg.spec.in Fri Mar 16 16:10:32 2012
@@ -5,7 +5,7 @@
Group: System/YaST
License: GPL-2.0
BuildRequires: doxygen dejagnu gcc-c++ yast2-core-devel yast2-devtools libtool
-BuildRequires: libxcrypt-devel blocxx-devel ncurses-devel yast2-ncurses-devel
+BuildRequires: blocxx-devel ncurses-devel yast2-ncurses-devel

Summary: YaST2 - Character Based Package Manager Frontend
Provides: yast2-ncurses:@plugindir@/libpy2ncurses.so

Modified: trunk/ncurses/yast2-ncurses.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/ncurses/yast2-ncurses.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/ncurses/yast2-ncurses.spec.in (original)
+++ trunk/ncurses/yast2-ncurses.spec.in Fri Mar 16 16:10:32 2012
@@ -5,7 +5,7 @@
Group: System/YaST
License: GPL-2.0
BuildRequires: doxygen dejagnu gcc-c++ yast2-devtools libtool
-BuildRequires: libxcrypt-devel blocxx-devel ncurses-devel
+BuildRequires: blocxx-devel ncurses-devel

Summary: YaST2 - Character Based User Interface
Provides: yast2_ui

Modified: trunk/openwsman-yast/openwsman-yast.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/openwsman-yast/openwsman-yast.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/openwsman-yast/openwsman-yast.spec.in (original)
+++ trunk/openwsman-yast/openwsman-yast.spec.in Fri Mar 16 16:10:32 2012
@@ -23,7 +23,7 @@
Source: %{name}-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Group: System/Management
-BuildRequires: openwsman >= 2.2.0 libwsman-devel >= 2.2.0 gcc-c++ pkgconfig
libxml2-devel yast2-core-devel libxcrypt-devel
+BuildRequires: openwsman >= 2.2.0 libwsman-devel >= 2.2.0 gcc-c++ pkgconfig
libxml2-devel yast2-core-devel
Requires: openwsman-server >= 2.2.0
Requires: yast2-core
Summary: YaST plugin for openwsman-server

Modified: trunk/packager/yast2-packager.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/packager/yast2-packager.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/packager/yast2-packager.spec.in (original)
+++ trunk/packager/yast2-packager.spec.in Fri Mar 16 16:10:32 2012
@@ -4,7 +4,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: gcc-c++ libxcrypt-devel yast2-country-data yast2-xml
perl-XML-Writer update-desktop-files yast2-devtools yast2-testsuite yast2-slp
+BuildRequires: gcc-c++ yast2-country-data yast2-xml perl-XML-Writer
update-desktop-files yast2-devtools yast2-testsuite yast2-slp

# HTTP.ycp
BuildRequires: yast2-transfer

Modified: trunk/perl-bindings/yast2-perl-bindings.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/perl-bindings/yast2-perl-bindings.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/perl-bindings/yast2-perl-bindings.spec.in (original)
+++ trunk/perl-bindings/yast2-perl-bindings.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: blocxx-devel curl-devel gcc-c++ libxcrypt-devel rpm-devel
yast2-core-devel yast2-devtools yast2-ycp-ui-bindings-devel libtool
+BuildRequires: blocxx-devel curl-devel gcc-c++ rpm-devel yast2-core-devel
yast2-devtools yast2-ycp-ui-bindings-devel libtool

# YCPValue::valuetype_str()
Requires: yast2-core >= 2.16.37

Modified: trunk/pkg-bindings/yast2-pkg-bindings-devel-doc.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/pkg-bindings/yast2-pkg-bindings-devel-doc.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/pkg-bindings/yast2-pkg-bindings-devel-doc.spec.in (original)
+++ trunk/pkg-bindings/yast2-pkg-bindings-devel-doc.spec.in Fri Mar 16 16:10:32
2012
@@ -11,7 +11,7 @@
Prefix: %_prefix

# same as in the main package (because we use the same configure.in.in)
-BuildRequires: blocxx-devel docbook-xsl-stylesheets doxygen libgcrypt-devel
libxcrypt-devel libxslt perl-XML-Writer sgml-skel yast2-core-devel
yast2-devtools libzypp-devel
+BuildRequires: blocxx-devel docbook-xsl-stylesheets doxygen libgcrypt-devel
libxslt perl-XML-Writer sgml-skel yast2-core-devel yast2-devtools libzypp-devel
BuildRequires: libtool gcc-c++

Buildarch: noarch

Modified: trunk/pkg-bindings/yast2-pkg-bindings.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/pkg-bindings/yast2-pkg-bindings.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/pkg-bindings/yast2-pkg-bindings.spec.in (original)
+++ trunk/pkg-bindings/yast2-pkg-bindings.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: blocxx-devel docbook-xsl-stylesheets doxygen libgcrypt-devel
libxcrypt-devel libxslt perl-XML-Writer sgml-skel yast2-core-devel
yast2-devtools
+BuildRequires: blocxx-devel docbook-xsl-stylesheets doxygen libgcrypt-devel
libxslt perl-XML-Writer sgml-skel yast2-core-devel yast2-devtools
BuildRequires: libzypp-devel >= 6.10.0
BuildRequires: libtool gcc-c++


Modified: trunk/profile-manager/yast2-profile-manager.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/profile-manager/yast2-profile-manager.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/profile-manager/yast2-profile-manager.spec.in (original)
+++ trunk/profile-manager/yast2-profile-manager.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0
-BuildRequires: gcc-c++ libxcrypt-devel scpm-devel doxygen perl-XML-Writer
yast2-devtools yast2-core-devel yast2-users yast2-testsuite
update-desktop-files libtool
+BuildRequires: gcc-c++ scpm-devel doxygen perl-XML-Writer yast2-devtools
yast2-core-devel yast2-users yast2-testsuite update-desktop-files libtool
# Wizard::SetDesktopTitleAndIcon
Requires: yast2 >= 2.21.22
Requires: yast2-users

Modified: trunk/python-bindings/yast2-python-bindings.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/python-bindings/yast2-python-bindings.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/python-bindings/yast2-python-bindings.spec.in (original)
+++ trunk/python-bindings/yast2-python-bindings.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0
-BuildRequires: blocxx-devel curl-devel gcc-c++ yast2-core-devel yast2-devtools
python-devel libxcrypt-devel yast2-ycp-ui-bindings-devel libtool
+BuildRequires: blocxx-devel curl-devel gcc-c++ yast2-core-devel yast2-devtools
python-devel yast2-ycp-ui-bindings-devel libtool


# YCPValue::valuetype_str()

Modified: trunk/qt-pkg/yast2-qt-pkg.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/qt-pkg/yast2-qt-pkg.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/qt-pkg/yast2-qt-pkg.spec.in (original)
+++ trunk/qt-pkg/yast2-qt-pkg.spec.in Fri Mar 16 16:10:32 2012
@@ -4,7 +4,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel
libxcrypt-devel
+BuildRequires: docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel
BuildRequires: libxslt perl-XML-Writer libqt4-devel sgml-skel
update-desktop-files

Summary: YaST2 - Graphical User Interface

Modified: trunk/qt/yast2-qt.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/qt/yast2-qt.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/qt/yast2-qt.spec.in (original)
+++ trunk/qt/yast2-qt.spec.in Fri Mar 16 16:10:32 2012
@@ -8,7 +8,6 @@
BuildRequires: doxygen
BuildRequires: libdrm-devel
BuildRequires: libjpeg-devel
-BuildRequires: libxcrypt-devel
BuildRequires: libxslt
BuildRequires: perl-XML-Writer
BuildRequires: libqt4-devel

Modified: trunk/ruby-bindings/yast2-ruby-bindings.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/ruby-bindings/yast2-ruby-bindings.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/ruby-bindings/yast2-ruby-bindings.spec.in (original)
+++ trunk/ruby-bindings/yast2-ruby-bindings.spec.in Fri Mar 16 16:10:32 2012
@@ -14,7 +14,7 @@
Source0: yast2-ruby-bindings-%{version}.tar.bz2
Prefix: /usr

-BuildRequires: swig cmake gcc-c++ libxcrypt-devel yast2-core-devel
+BuildRequires: swig cmake gcc-c++ yast2-core-devel
BuildRequires: yast2-devtools >= 2.16.3
# libzypp-devel is missing .la requires
BuildRequires: ruby-devel

Modified: trunk/slp/yast2-slp.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/slp/yast2-slp.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/slp/yast2-slp.spec.in (original)
+++ trunk/slp/yast2-slp.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: gcc-c++ libxcrypt-devel openslp-devel doxygen perl-XML-Writer
yast2-devtools yast2-core-devel yast2 libtool
+BuildRequires: gcc-c++ openslp-devel doxygen perl-XML-Writer yast2-devtools
yast2-core-devel yast2 libtool
Requires: openslp
# Wizard::SetDesktopTitleAndIcon
Requires: yast2 >= 2.21.22

Modified: trunk/storage/yast2-storage.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/storage/yast2-storage.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/storage/yast2-storage.spec.in (original)
+++ trunk/storage/yast2-storage.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: blocxx-devel boost-devel gcc-c++ libtool libxcrypt-devel
openssl-devel sablot swig
+BuildRequires: blocxx-devel boost-devel gcc-c++ libtool openssl-devel sablot
swig
BuildRequires: docbook-xsl-stylesheets doxygen libxslt perl-XML-Writer
sgml-skel update-desktop-files
BuildRequires: libstorage-devel >= 2.21.11 yast2 >= 2.19.4 yast2-core-devel >=
2.18.1 yast2-devtools
BuildRequires: yast2-testsuite >= 2.19.0 yast2-perl-bindings

Modified: trunk/transfer/yast2-transfer.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/transfer/yast2-transfer.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/transfer/yast2-transfer.spec.in (original)
+++ trunk/transfer/yast2-transfer.spec.in Fri Mar 16 16:10:32 2012
@@ -3,7 +3,7 @@
@HEADER@
Group: System/YaST
License: GPL-2.0+
-BuildRequires: curl-devel gcc-c++ libxcrypt-devel perl-XML-Writer
update-desktop-files yast2 yast2-devtools yast2-testsuite doxygen
yast2-core-devel libtool
+BuildRequires: curl-devel gcc-c++ perl-XML-Writer update-desktop-files yast2
yast2-devtools yast2-testsuite doxygen yast2-core-devel libtool
Summary: YaST2 - Agent for Various Transfer Protocols
Provides: yast2-agent-curl yast2-agent-tftp yast2-agent-curl-devel
yast2-agent-tftp-devel
Obsoletes: yast2-agent-curl yast2-agent-tftp yast2-agent-curl-devel
yast2-agent-tftp-devel

Modified: trunk/ycp-ui-bindings/yast2-ycp-ui-bindings.spec.in
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/ycp-ui-bindings/yast2-ycp-ui-bindings.spec.in?rev=67652&r1=67651&r2=67652&view=diff
==============================================================================
--- trunk/ycp-ui-bindings/yast2-ycp-ui-bindings.spec.in (original)
+++ trunk/ycp-ui-bindings/yast2-ycp-ui-bindings.spec.in Fri Mar 16 16:10:32 2012
@@ -19,9 +19,6 @@
BuildRequires: yast2-core-devel
Conflicts: yast2-core < 2.16.38

-# libycp includes crypto built-ins
-BuildRequires: libxcrypt-devel
-
Requires: yast2-libyui >= 2.21.1
BuildRequires: yast2-libyui-devel >= 2.21.1

@@ -45,7 +42,6 @@
Requires: boost-devel
Requires: yast2-libyui-devel
Requires: yast2-core-devel
-Requires: libxcrypt-devel
Requires: yast2-devtools

%description devel

--
To unsubscribe, e-mail: yast-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages