Mailinglist Archive: yast-commit (723 mails)

< Previous Next >
[yast-commit] r47330 - in /trunk/update: VERSION package/yast2-update.changes src/clients/inst_update.ycp src/clients/run_update.ycp src/clients/update_proposal.ycp src/modules/Update.ycp
  • From: locilka@xxxxxxxxxxxxxxxx
  • Date: Tue, 06 May 2008 16:49:50 -0000
  • Message-id: <20080506164950.E703729A73@xxxxxxxxxxxxxxxx>
Author: locilka
Date: Tue May 6 18:49:50 2008
New Revision: 47330

URL: http://svn.opensuse.org/viewcvs/yast?rev=47330&view=rev
Log:
- Removed support for 'delete unmaintained packages' from
configuration UI as it is no longer supported by libzypp and
replaced with list of packages to delete defined in control
file (bnc #300540).
- 2.16.9


Modified:
trunk/update/VERSION
trunk/update/package/yast2-update.changes
trunk/update/src/clients/inst_update.ycp
trunk/update/src/clients/run_update.ycp
trunk/update/src/clients/update_proposal.ycp
trunk/update/src/modules/Update.ycp

Modified: trunk/update/VERSION
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/VERSION?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/VERSION (original)
+++ trunk/update/VERSION Tue May 6 18:49:50 2008
@@ -1 +1 @@
-2.16.8
+2.16.9

Modified: trunk/update/package/yast2-update.changes
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/package/yast2-update.changes?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/package/yast2-update.changes (original)
+++ trunk/update/package/yast2-update.changes Tue May 6 18:49:50 2008
@@ -1,4 +1,13 @@
-------------------------------------------------------------------
+Tue May 6 18:47:09 CEST 2008 - locilka@xxxxxxx
+
+- Removed support for 'delete unmaintained packages' from
+ configuration UI as it is no longer supported by libzypp and
+ replaced with list of packages to delete defined in control
+ file (bnc #300540).
+- 2.16.9
+
+-------------------------------------------------------------------
Tue Apr 29 13:31:05 CEST 2008 - locilka@xxxxxxx

- Progress for "searching for partitions" (bnc #384707).

Modified: trunk/update/src/clients/inst_update.ycp
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/src/clients/inst_update.ycp?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/src/clients/inst_update.ycp (original)
+++ trunk/update/src/clients/inst_update.ycp Tue May 6 18:49:50 2008
@@ -110,11 +110,11 @@
)
)
),
- `VSpacing (1),
- `Left(`CheckBox(`id(`delete),
- // check box label
- // translator: add a & shortcut
- _("&Delete Unmaintained Packages"), true)),
+// `VSpacing (1),
+// `Left(`CheckBox(`id(`delete),
+// // check box label
+// // translator: add a & shortcut
+// _("&Delete Unmaintained Packages"), true)),
`VSpacing(1),
`Label( `id(`wrn_label), wrn_msg )
)
@@ -163,7 +163,7 @@
UI::ChangeWidget(`id(sel), `Enabled, !Update::onlyUpdateInstalled);
});

- UI::ChangeWidget(`id(`delete), `Value, Update::deleteOldPackages);
+// UI::ChangeWidget(`id(`delete), `Value, Update::deleteOldPackages);

any ret = nil;
boolean details_pressed = false;
@@ -216,8 +216,8 @@
something_changed = true;
}

- if (UI::QueryWidget (`id(`delete), `Value ) !=
Update::deleteOldPackages)
- something_changed = true;
+// if (UI::QueryWidget (`id(`delete), `Value ) !=
Update::deleteOldPackages)
+// something_changed = true;

if (something_changed && Packages::base_selection_modified)
{
@@ -237,7 +237,7 @@

boolean b1 = Update::onlyUpdateInstalled;
Update::onlyUpdateInstalled = (boolean) UI::QueryWidget
(`id(`notupgrade), `Value);
- Update::deleteOldPackages = (boolean) UI::QueryWidget (`id(`delete),
`Value);
+// Update::deleteOldPackages = (boolean) UI::QueryWidget (`id(`delete),
`Value);

if (Packages::using_patterns)
{

Modified: trunk/update/src/clients/run_update.ycp
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/src/clients/run_update.ycp?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/src/clients/run_update.ycp (original)
+++ trunk/update/src/clients/run_update.ycp Tue May 6 18:49:50 2008
@@ -28,7 +28,7 @@

Update::disallow_upgrade = true;
Update::onlyUpdateInstalled = true;
- Update::deleteOldPackages = false;
+// Update::deleteOldPackages = false;

ProductControl::custom_control_file =
"/usr/share/YaST2/control/update.xml";


Modified: trunk/update/src/clients/update_proposal.ycp
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/src/clients/update_proposal.ycp?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/src/clients/update_proposal.ycp (original)
+++ trunk/update/src/clients/update_proposal.ycp Tue May 6 18:49:50 2008
@@ -51,9 +51,10 @@
// 'nil' values are skipped, in that case, ZYPP uses own default values
map <string, boolean> ret = $[];

- if (Update::deleteOldPackages != nil) {
- ret["delete_unmaintained"] = Update::deleteOldPackages;
- }
+// not supported by libzypp anymore
+// if (Update::deleteOldPackages != nil) {
+// ret["delete_unmaintained"] = Update::deleteOldPackages;
+// }

if (Update::silentlyDowngradePackages != nil) {
ret["silent_downgrades"] = Update::silentlyDowngradePackages;
@@ -522,10 +523,10 @@
});
}

- if (Update::deleteOldPackages) {
- // Proposal for removing packages which are not maintained any more
- summary_text = summary_text + "<li>" + _("Delete unmaintained
packages") + "</li>\n";
- }
+// if (Update::deleteOldPackages) {
+// // Proposal for removing packages which are not maintained any more
+// summary_text = summary_text + "<li>" + _("Delete unmaintained
packages") + "</li>\n";
+// }

if (Update::onlyUpdateInstalled) {
// Proposal for backup during update

Modified: trunk/update/src/modules/Update.ycp
URL:
http://svn.opensuse.org/viewcvs/yast/trunk/update/src/modules/Update.ycp?rev=47330&r1=47329&r2=47330&view=diff
==============================================================================
--- trunk/update/src/modules/Update.ycp (original)
+++ trunk/update/src/modules/Update.ycp Tue May 6 18:49:50 2008
@@ -17,6 +17,7 @@
import "Installation";
import "Packages";
import "ProductFeatures";
+ import "ProductControl";
import "Stage";
import "SuSERelease";
import "Mode";
@@ -36,8 +37,8 @@
// number of errors (packages?) returned by solver
global integer solve_errors = 0;

- // Flag is set true if the user decides to delete unmaintained packages
- global boolean deleteOldPackages = nil;
+// // Flag is set true if the user decides to delete unmaintained packages
+// global boolean deleteOldPackages = nil;

// Flag is set to true when package downgrade is allowed
global boolean silentlyDowngradePackages = nil;
@@ -115,6 +116,9 @@
* Returns whether old packages should be removed (defined in control
file).
* True means - delete old RPMs when updating. (Functionality for FATE
#301844).
*/
+/*
+ // not supported by libzypp anymore
+
global boolean DeleteOldPackages () {
// changes deleteOldPackages variable
any default_dop_a = ProductFeatures::GetFeature ("software",
"delete_old_packages");
@@ -149,6 +153,7 @@

return default_dop;
}
+*/

/**
* Returns whether upgrade process should only update installed packages or
@@ -354,6 +359,30 @@
}

/**
+ * Drops packages defined in control file (string)
software->dropped_packages
+ *
+ * @see bnc #300540
+ */
+ void DropObsoletePackages () {
+ string packages_to_drop = ProductFeatures::GetStringFeature
("software", "dropped_packages");
+
+ if (packages_to_drop == nil || packages_to_drop == "") {
+ y2milestone ("No obsolete packages to drop");
+ return;
+ }
+
+ list <string> l_packages_to_drop = splitstring (packages_to_drop, ", ");
+ y2milestone ("Packages to drop: %1", l_packages_to_drop);
+
+ foreach (string one_package, l_packages_to_drop, {
+ if (Pkg::PkgInstalled (one_package) || Pkg::IsSelected
(one_package)) {
+ y2milestone ("Package to delete: %1", one_package);
+ Pkg::PkgDelete (one_package);
+ }
+ });
+ }
+
+ /**
*
*/
global define void Reset ()
@@ -362,8 +391,11 @@

Update::InitUpdate();

- deleteOldPackages = DeleteOldPackages();
- y2milestone ("deleteOldPackages %1", deleteOldPackages);
+ // bnc #300540
+ DropObsoletePackages();
+
+// deleteOldPackages = DeleteOldPackages();
+// y2milestone ("deleteOldPackages %1", deleteOldPackages);

onlyUpdateInstalled = OnlyUpdateInstalled();
y2milestone ("onlyUpdateInstalled %1", onlyUpdateInstalled);

--
To unsubscribe, e-mail: yast-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages