Mailinglist Archive: yast-commit (815 mails)

< Previous Next >
[yast-commit] r40010 - in /trunk/pkg-bindings: src/Resolvable.cc yast2-pkg-bindings.spec.in
  • From: lslezak@xxxxxxxxxxxxxxxx
  • Date: Mon, 06 Aug 2007 14:10:29 -0000
  • Message-id: <20070806141029.68688C846E@xxxxxxxxxxxxxxxx>
Author: lslezak
Date: Mon Aug  6 16:10:29 2007
New Revision: 40010

URL: http://svn.opensuse.org/viewcvs/yast?rev=40010&view=rev
Log:
- Pkg::ResolvableProperties() - returns type of product (key "TYPE"
  in SUSEtags content file)

Modified:
    trunk/pkg-bindings/src/Resolvable.cc
    trunk/pkg-bindings/yast2-pkg-bindings.spec.in

Modified: trunk/pkg-bindings/src/Resolvable.cc
URL: http://svn.opensuse.org/viewcvs/yast/trunk/pkg-bindings/src/Resolvable.cc?rev=40010&r1=40009&r2=40010&view=diff
==============================================================================
--- trunk/pkg-bindings/src/Resolvable.cc (original)
+++ trunk/pkg-bindings/src/Resolvable.cc Mon Aug  6 16:10:29 2007
@@ -437,6 +437,7 @@
                        info->add(YCPString("short_name"), YCPString(product_summary));
                    }
 
+                   info->add(YCPString("type"), YCPString(product->type()));
 
                    YCPList updateUrls;
                    std::list<zypp::Url> pupdateUrls = product->updateUrls();

Modified: trunk/pkg-bindings/yast2-pkg-bindings.spec.in
URL: http://svn.opensuse.org/viewcvs/yast/trunk/pkg-bindings/yast2-pkg-bindings.spec.in?rev=40010&r1=40009&r2=40010&view=diff
==============================================================================
--- trunk/pkg-bindings/yast2-pkg-bindings.spec.in (original)
+++ trunk/pkg-bindings/yast2-pkg-bindings.spec.in Mon Aug  6 16:10:29 2007
@@ -2,11 +2,11 @@
 
 @HEADER@
 BuildRequires: blocxx-devel docbook-xsl-stylesheets doxygen gcc-c++ libgcrypt-devel libxcrypt-devel libxslt perl-XML-Writer rpm-devel sgml-skel yast2-core-devel yast2-devtools boost boost-devel dbus-1-devel hal-devel
-BuildRequires: libzypp-devel >= 3.11.8
-BuildRequires: libzypp >= 3.11.8
+BuildRequires: libzypp-devel >= 3.13.11
+BuildRequires: libzypp >= 3.13.11
 
 # new API (RepoManager instead of SourceManager)
-Requires:      libzypp >= 3.11.8
+Requires:      libzypp >= 3.13.11
 
 Summary:       -
 

--
To unsubscribe, e-mail: yast-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages