Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
Re: [radeonhd] Initial RandR 1.2 support (for the brave of heart ;)
  • From: "Felipe Contreras" <felipe.contreras@xxxxxxxxx>
  • Date: Mon, 19 Nov 2007 11:55:53 +0200
  • Message-id: <94a0d4530711190155s7234617ey79903535d0818cdd@xxxxxxxxxxxxxx>
Hi,

On Nov 14, 2007 3:34 PM, Matthias Hopf <mhopf@xxxxxxx> wrote:
On Nov 14, 07 13:10:02 +0200, Felipe Contreras wrote:
Yeah, I did that before doing those tests since I had compilation
issues (autogen and everything).

I downloaded the latest code and tried again and now
Ctrl+Alt+Backspace works, but I still have a black screen.

I just pushed some missing bits for the noRandR case. Could you please
try initial-randr again, with 'Option "noRandR"' set? The order of
initialization in ScreenInit is still different, and I hope it doesn't
make any difference...

I fetched dce9ffc402511d0820c0fcdd7228e1f2ce8571fc and now norandr
works fine, and actually randr too.

This is what I get:

Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1600 x 1600
VGA_CRT1/DAC_A disconnected
PANEL_LCD1/LVDS/TMDS unknown connection 1400x1050+0+0 287mm x 215mm
1400x1050 60.0*+ 50.0
1280x1024 59.9
1360x768 59.8 60.0
1280x800 60.0
1152x864 60.0
1280x768 60.0
1280x720 60.0
1024x768 60.0
800x600 60.3
640x480 60.0 59.9
DVI-I_DFP1/TMDS_A connected 1400x1050+0+0 408mm x 306mm
1600x1200 60.0 + 59.9
1400x1050 74.9* 60.0
1280x1024 75.0 59.9
1280x960 59.9
1152x864 75.0 74.8
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 75.0 72.8 66.7 60.0
720x400 70.1

I tried:
xrandr --output DVI-I_DFP1/TMDS_A -s 1600x1200

But nothing happens.

At least there is improvement :)

Best regards.

--
Felipe Contreras
--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups