Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
Re: [radeonhd] AMD64 based RS690T system and RadeonHD driver almost works under FreeBSD
  • From: Coleman Kane <cokane@xxxxxxxxxxx>
  • Date: Mon, 12 Nov 2007 08:56:04 -0500
  • Message-id: <47385B74.7010801@xxxxxxxxxxx>
Coleman Kane wrote:
Egbert Eich wrote:

Coleman Kane writes:
> I have been messing around with this further and I don't know what I did
> but now radeonhd works on this notebook @ 1680x1050x24bpp (what I
> want)... I've been flipping around with a number of different xorg.conf
> options with the vesa and the avivo drivers (both of which won't let X11
> start). Finally, I tried 'radeonhd' again and it just worked! I even
> rebooted the notebook (hard power off then back on) just in case it was
> a fluke, and what ever it is seems to be working consistently.

I've diffed your two log files. There is nothing that would indicate any
substantial difference.

diff working non-working
< (==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 9 15:38:44 2007

(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 9 02:39:23 2007


(**) RADEONHD(0): Option "NoAccel" "false"


(EE) RADEONHD(0): D1CRTCDisable: Failed to Unsync CRTC 1

< (WW) RADEONHD(0): Option "IgnoreEDID" is not used

NoAccel should not have any effect (we presently don't have accel),
IgnoreEDID is not used.

I'm not sure why you were hitting the 'Failed to Unsync CRTC 1'
did you run fglrx before radeonhd without rebooting?

Nope, I can't run fglrx since I am on FreeBSD/amd64. I had been
switching between avivo and vesa drivers though... I am not even sure
what the ramifications of that error message are. I was previously
getting a pretty garbled screen (however everything else seemed to work,
it just was completely unviewable). Now I get a good working display...

Maybe my problem was that one of the other drivers (likely avivo?) was
leaving the display in a messed-up state and I just happened to run
radeonhd directly after that driver, and never tried a second time.
Anyhow, I've been running radeonhd for days now, rebooting and
restarting numerous times. All seems well....

I've thought about it more... One thing I did do before I got this
working was that I did run the server using the VGA driver. It came up
in 320x240 or a similar mode. But this was the first time I got X to
display properly. This laptop never had windows installed on it (HP
offers a FreeDOS option instead), so I am curious if perhaps my TFT
panel or RS690 needed some extra kick (given by the vga driver) to
properly display, but the radeonhd driver wasn't doing that.

Coleman Kane

To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >