Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
Re: [radeonhd] AMD64 based RS690T system and RadeonHD driver almost works under FreeBSD
  • From: Coleman Kane <cokane@xxxxxxxxxx>
  • Date: Mon, 12 Nov 2007 07:37:11 -0500
  • Message-id: <473848F7.3060603@xxxxxxxxxx>
Egbert Eich wrote:
Coleman Kane writes:
> I have been messing around with this further and I don't know what I did
> but now radeonhd works on this notebook @ 1680x1050x24bpp (what I
> want)... I've been flipping around with a number of different xorg.conf
> options with the vesa and the avivo drivers (both of which won't let X11
> start). Finally, I tried 'radeonhd' again and it just worked! I even
> rebooted the notebook (hard power off then back on) just in case it was
> a fluke, and what ever it is seems to be working consistently.

Woops.
I've diffed your two log files. There is nothing that would indicate any
substantial difference.

diff working non-working
13c13
< (==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 9 15:38:44 2007
---

(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 9 02:39:23 2007

434a435

(**) RADEONHD(0): Option "NoAccel" "false"

617a619

(EE) RADEONHD(0): D1CRTCDisable: Failed to Unsync CRTC 1

623d624
< (WW) RADEONHD(0): Option "IgnoreEDID" is not used

NoAccel should not have any effect (we presently don't have accel),
IgnoreEDID is not used.

I'm not sure why you were hitting the 'Failed to Unsync CRTC 1'
did you run fglrx before radeonhd without rebooting?

Nope, I can't run fglrx since I am on FreeBSD/amd64. I had been
switching between avivo and vesa drivers though... I am not even sure
what the ramifications of that error message are. I was previously
getting a pretty garbled screen (however everything else seemed to work,
it just was completely unviewable). Now I get a good working display...

Maybe my problem was that one of the other drivers (likely avivo?) was
leaving the display in a messed-up state and I just happened to run
radeonhd directly after that driver, and never tried a second time.
Anyhow, I've been running radeonhd for days now, rebooting and
restarting X.org numerous times. All seems well....

--
Coleman Kane


--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups