Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
Re: [radeonhd] AMD64 based RS690T system and RadeonHD driver almost works under FreeBSD
  • From: Coleman Kane <cokane@xxxxxxxxxxx>
  • Date: Fri, 09 Nov 2007 08:18:43 -0500
  • Message-id: <47345E33.5070607@xxxxxxxxxxx>
Rene Ladan wrote:
2007/11/9, Coleman Kane <cokane@xxxxxxxxxxx>:

Hello,

I just recently got an HP Compaq 6715b laptop with an ATI Radeon Xpress
X1270 in it. I am trying to get this card working under FreeBSD and
X.org 7.3, and so far the RadeonHD driver has been the closest thing to
get it working (vesa, radeon, and avivo all die).


radeon is only meant for <= R4xx cards so it can't handle RadeonHD cards.
VESA works on my M64P (X1450 Mobility) card though. I never got avivo
working properly.


The log output for radeonhd says "Unkown Card Detected:
0x791F:0x103C:0x30C2".


This shouldn't be a problem. It's a remnant from the time when the detection
of
connector layouts were entered manually into the code. The current
driver uses AtomBIOS for that.


The EDID stuff gives Horiz timing of only 64.1kHz and Vert timing of
only 60.1Hz (making it impossible to allow other video modes to test)

There is also one error stating that "D1CRTCDisable: Failed to Unsync
CRTC 1".


I think the driver chokes on this.

I am attaching my Xorg.0.log in case anything sticks out... I tried
using the rhd_conntest, but it doesn't seem to work appropriately on my
machine.


Using libpci-2.2.8 from ports you should be able to dump your AtomBIOS
with rhd_conntest using the -d option. Showing the connector layout
doesn't work on my i386 CURRENT box.

I'll send-pr an update for the port (x11-drivers/xf86-video-radeonhd)
once the ports freeze is over.


I would really like to get this working on this laptop ASAP so let me
know where I can start. I've scoured the internet looking for
information, and it seems that most Linux users are using the fglrx
driver instead (which is a no-go for me as there's no amd64 fglrx for
FreeBSD).


I've toyed around with fglrx too a bit, but never made it properly
through the installer.

Regards,
Rene

The current HEAD from anongit.freedesktop.org actually starts up X and
seems to work, except that the screen is extremely garbled. I can move
the mouse around and see a garbled cursor move around on the display. I
forgot to mention that it behaves this way in the email. So X does load
up and I do get a display, it is just completely unusable. Also, I get a
message from rhd_conntest that reads "Unable to map IO memory: No such
file or directory.", however I just realized that it is creating a
.vga.rom file, so I am attaching this.

--
Coleman Kane

< Previous Next >