Mailinglist Archive: opensuse (950 mails)

< Previous Next >
[opensuse] alias egrep failure (for zypper)
In order to make it easier than routinely typing

zypper se -s packagestring | grep x86 | egrep -v 'src|devel|xtra'

I tried to make an alias:
alias zse6='zypper se -s $1 | grep x86 | egrep -v "src|devel|xtra" '

but it produces:
# zse6 packagestring
egrep: packagestring: No such file or directory

What needs changing to return x86_64 packages exclusive of src, devel and
xtra that contain the string packagestring? Why is egrep looking for any file
or directory? If I swap each ' for " and vice versa, results are even worse.
I tried escaping pipes and quotes, but it didn't get any better.

Anyone know an easier way than manually typing

zypper se -s packagestring | grep x86 | egrep -v 'src|devel|xtra'

for x86_64 users to exclude 32 bit packages from search results?
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation