Mailinglist Archive: opensuse (671 mails)

< Previous Next >
SV: SV: SV: [opensuse] vmtools problem...
  • From: "Anders Norrbring" <lists@xxxxxxxxxxxx>
  • Date: Sun, 26 Jun 2011 18:54:31 +0200
  • Message-id: <001a01cc3421$b8259e60$2870db20$@se>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

At 26.06.2011 12:34, Anders Norrbring wrote:

The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does
not match
your running kernel (version 2.6.37.6-0.5-default). Even if the
module were to
compile successfully, it would not load into the running kernel.

Andres,

yes, this is one of the reasons why I changed from VMWare to
VirtualBox.

Did you do a "make cloneconfig && make prepare" in /usr/src/linux? I
think this was necessary on older SUSEs. And is there a version of the
"any-any-patch" you can install? (mentioned in
<http://tr.opensuse.org/Setting_up_VMware_on_SUSE_Linux>)

Maybe you can give the open vmtools a try and rpmbuild your own version
from the vmware repo on the buildservice?
<http://download.opensuse.org/repositories/Virtualization:/VMware/>

HTH
Werner

Werner,
All of the above is tried, it just won't work.. vmtoolsd from the open-vmtools
states this in the messages log:
vmsvc[2240]: [ warning] [vmtoolsd] The vmsvc service needs to run inside a
virtual machine.
So for some reason vmsvc doesn't recognize that it's running in a VMware guest.

Anders.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups