Mailinglist Archive: opensuse (963 mails)

< Previous Next >
Re: [opensuse] BIOS/GRUB Problem
  • From: Stan Goodman <stan.goodman@xxxxxxxxxxxxx>
  • Date: Mon, 8 Nov 2010 14:17:44 +0200
  • Message-id: <201011081417.44437.stan.goodman@xxxxxxxxxxxxx>
On Monday 08 November 2010 09:58:16 Stan Goodman wrote:
On Monday 08 November 2010 01:51:10 Felix Miata wrote:
On 2010/11/07 23:25 (GMT+0200) Stan Goodman composed:
I guess the way to go for fsck information would be to find a forum
concerned with GRUB.

Once you see any of the kernel & init messages leading up to the
recovery shell prompt, Grub has long since finished doing anything
it can do. Discussing this on a Grub forum would be 100% off-topic.

Then beyond a Google search on "fsck", the obvious clear next stip is
reinstall, .....

There have been developments.

Remembering your caveat that there were likely to be problems in running
fsck manually when it had failed to produce results automatically, I
decided to run it once, simply to get a feel for how it worked, so I ran:

fsk /dev/sda6

which caused it to ask for confirmation to correct errors. When it
finished, I rebooted to the same repair screen, ran fsck again, and it
reported that sda6 was clean, which was very rewarding. The "failed" line
in the actions report, which was about inconsistent system clock, was now
marked "skipped" instead. Actually, it is the date that is wrong, being
sometime in 2002; the time of day, which I had set after the resetting of
the BIOS, is accurate.

Then I wondered why, if sda6 was clean, why I had been returned to the
repair screen, and so noticed that the INCONSISTENCY it had been worrying
about was now reported on sda7 (the /home partition), so I ran fsck on
that partition.

A reboot brought the system to its present state, which is that the
desktop is now up partially. The chameleon is still there, with the
progress gauge (with no progress), but the upper-left quadrant is occupied
by the Desktop Folder window. neither the folder nor the rest of the
screen is populated.

This would seem to be progress. What I would like to do is to run fsk on
sda7 again, but I am unsure how to reboot, since there is no button to do
so, and I am reluctant to screw things up again by using the OFF switch.
Actually, I think that switch does an orderly shutdown before removing
power, but I would like to be sure.

Stan Goodman
Qiryat Tiv'on
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups