Mailinglist Archive: opensuse (963 mails)

< Previous Next >
Re: [opensuse] Need help getting a wireless adapter to work
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Thu, 04 Nov 2010 13:50:30 -0500
  • Message-id: <4CD30076.3040305@xxxxxxxxxxxxxxxxxx>
On 11/03/2010 07:16 PM, Marc Chamberlin wrote:
Thanks again Kanenas, David for your suggestions... I have followed your
and removed all my wireless entries from Yast, and from
Then starting from ground zero reinstalled the wireless USB dongle with YaST.
That got me to where wlan0 is now considered my wireless network interface.
Restarted the network, and rebooted, but still no joy getting it to actually

There is something rotten in Denmark...

I checked the AP, it is a Linksys WAP54G and the SSID broadcast is enabled. (I
presume this is the setting you were referring to, and as I mentioned
my laptop sees the ESSID when running under Windoz)

Yep, that's the one. I missed the windows part. Linksys Wireless have been great
for me (still running older WRT54Gs), so the setup there is simple and just
works (as it does for you from windows)

Why not use ndiswrapper and use your windows drivers in Linux?

I also noted that my Linksys
AP was configured to use channel 6, and the iwconfig was reporting that the
Encore wireless adapter was using the freq for channel 1. So I manually set
'WIRELESS_CHANNEL' to '6' in my ifcfg-wlan0 file in the
dir. (Couldn't figure out how to do that via YaST) But still no joy!

So now iwconfig gives this report -

marcslaptop:/etc/sysconfig/network # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"CHAMBERLIN"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=11 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:1234-1234-1234-1234-1234-1234-12
Power Management:on
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

David, you also mentioned the Broadcom driver and asked me to search for it
Google. I don't understand why Broadcom?

It must have been late and I must have been thinking about another wireless
issue. Just disregard :-)

It is always worth filing a bug report concerning the wireless issue. As
mentioned, I have found kernel module alias mismatches with other wireless
chipsets. If yast is selecting the module for you, then it should select one
that works. If not, then the smart folks need to figure out why it doesn't.

You have the best clean config you can have now. persistent-net.rules is now
fixed and wlan0 is what you want to work with. (although in theory it doesn't

If I had a usb wireless chip giving me that much trouble, I'd 3 pt. it right
into file 13 and start over. See what the other recommendations are and post
back when you are ready to configure it. We have pretty much exhausted my bag of
wireless tricks...

David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >