Mailinglist Archive: opensuse (1196 mails)

< Previous Next >
Re: [opensuse] Why is root device hardcoded in initrd and how could it be prevented?
  • From: Istvan Gabor <suseuser04@xxxxxxx>
  • Date: Mon, 18 Jan 2010 15:52:59 +0100
  • Message-id: <191d6895.7a0a1b65.4b5475cb.5642e@xxxxx>
2010. január 18. 13:41 napon Per Jessen <per@xxxxxxxxxxxx> írta:

Istvan Gabor wrote:


Recently I had more times boot problems with openSUSE 11.1 and 11.2
after cloning/copying the operating system from one partition to
another. Even if I adjusted fstab and boot manager (grub) according to
the new location the boot stopped with errors like this one:

"Waiting for device /dev/disk/by-id/ata-MaxtorXXXXXX-part3 to appear.
Could not find /dev/disk/by-id/ata-MaxtorXXXXXX-part3
Want me to fallback to /dev/disk/by-id/ata-MaxtorXXXXXX-part3 (y/n)"

The device the message cites hosted the root partition of the system
before cloning. It seems that this information is hardcoded in initrd.

Why is the root device hardcoded in initrd? How could this hardcoding
be prevented?

Hello Istvan

AFAIK, it's not actually "hardcoded", but generated during the
installation. It's annoying, but the work-around is to rebuild the
initrd when you clone a system.

Yes, I tried it. I have two problems with this solution:

1. I don't know how to make an initrd image to the system if it is not running.
Do you know how to create initrd image for a system which is not running?

2. I used the install DVD to boot the copied system and ran mkinitrd. This
solution worked but the new initrd can boot only in text mode, graphical boot
mode is lost. There is a graphical message window but after that step booting
always continues in text mode.
How can I make an initrd image that allows graphical boot?


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups