Mailinglist Archive: opensuse (1702 mails)

< Previous Next >
Re: [opensuse] Re: ldap slpd config
  • From: Ralf Haferkamp <rhafer@xxxxxxx>
  • Date: Fri, 11 Sep 2009 10:02:00 +0200
  • Message-id: <200909111002.00750.rhafer@xxxxxxx>
Am Freitag 11 September 2009 09:18:46 schrieb Linda Walsh:
Ralf Haferkamp wrote:
Am Montag 07 September 2009 13:33:30 schrieb Linda Walsh:
Ralf Haferkamp wrote:
You (your client, whatever tool you used) tried to authenticate using
the SASL/GSSAPI mechanism, but you server is not configured to use that
mechanism. What tool were you using to access the LDAP server? If you
were using the ldapsearch tool try adding the "-x" commandline switch
to use simple authentication and see if that works. For details have a
look in the ldapsearch man-page.

I was using the command listed below -- that YAST told me to use:
ldapsearch -Y external -H ldapi:/// -b

That command whould never ever give you the error message you pasted in
your first mail ("SASL [conn=1] Failure: GSSAPI Error: ....").

But it did. I cut and pasted the command and the error...

What does this command give you:

ldapsearch -x -H ldap://<your.ldapserver.address> -b "" -s base +

Unfortunately you didn't answer this question.

Wow...that worked! Excellent...some output...
(I used "localhost" as my server, using the server name doesn't seem to
Ok. So your ldapserver is listening on the normal LDAP server port and
accepting connections (if using the hostname does not work, it seems that
your name service configuration is somehow screwed, or a firewall is getting
in your way).
What still doesn't seem to work it the access via ldapi:// as used by the YaST
ldap-server module. Did you check /etc/sysconfig/openldap as stated in my
first mail? Also please check the commandline arguments that slapd is started
ps axuw | grep slapd

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups