Mailinglist Archive: opensuse (1702 mails)

< Previous Next >
Re: [opensuse] Kernel Compiling
  • From: Richard <ricreig@xxxxxxxxx>
  • Date: Wed, 9 Sep 2009 10:57:37 -0400
  • Message-id: <200909091057.38121.ricreig@xxxxxxxxx>
On Wed September 9 2009 4:34:38 am ne... wrote:
On Wed, Sep 9, 2009 at 09:20, Richard<ricreig@xxxxxxxxx> wrote:
On Wed September 9 2009 4:13:58 am Heinz Diehl wrote:
At Wed, 9 Sep 2009 03:17:08 -0400,
Richard wrote:

/usr/include/bits/socket.h:334:24: error: asm/socket.h: No such file or

This means your installed kernel sources are broken (incomplete).


In the include directory, you will find various 'asm-xxx' directories.
Try making a
sym link to the one you are compiling for e.g. ln -s ../asm-alpha ../asm

This might or might not work. I haven't needed to compile a kernel in the
last 3 years so I'm not to scratch with this stuff.

Thanks for the hint, but no combination of links would work. I put 'ln -s
../asm-generic ../asm in ...

/usr/src/<kernel I was trying to build>/
/usr/src/<kernel I was trying to build>/include
/usr/src/<kernel I was trying to build>/include/asm-generic
...and a few others

...replaced '../asm-generic' with the name of the assembler ...
'ln -s /usr/bin/as86 ./asm' and variations of that theme

Unfortunately, the error message was the same with all tries. No difference.

I tried with 4 other kernel source directories, one of which was created by
extracting from a *.tgz tarball. Nada, still the *exact* same error message
when using 'make <anything>'

I'm stumped, but I thank you for your responses.

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups