Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] WARNING! re latest update to OpenOffice from Novell -- RESOLVED ('mysteriously')
  • From: Anders Johansson <ajohansson@xxxxxxx>
  • Date: Sat, 31 Jan 2009 13:58:08 +0100
  • Message-id: <200901311358.08160.ajohansson@xxxxxxx>
On Saturday 31 January 2009 13:47:58 Basil Chupin wrote:
Basil Chupin wrote:
Basil Chupin wrote:
Anders Johansson wrote:
On Saturday 31 January 2009 09:07:07 Basil Chupin wrote:
Just to be sure, do not allow YaST/zypper (or even smart) to update
your (32-bit) 11.1 installation of OpenOffice to the latest version -
leave it at 3.0.0.9-1.11.

It works on 11.1 as well. There were a few issues with dependencies
which need to be reported to the packager though. e.g.
OpenOffice_org-libs-gui, OpenOffice_org-libs-core and
OpenOffice-components do not seem to have replacements in 3.0.1, so
they should have been removed, but weren't. They were still around at
version 3.0.0.9, causing conflicts. But simply

rpm -e OpenOffice_org-libs-gui OpenOffice_org-libs-core
OpenOffice-components

made everything work again

Anders

Well when installing here all the *-extensions and the *filters-optional
RPMs are marked for deletion but they are not deleted and cause the
dependency problems. OK, they can be manually deleted but there is one
more RPM which simply cannot be removed because it is needed by some
3009 files (which will be replaced by the update anyway); this RPM is
OpenOffice_org-l10n-extras-3.0.0.9-1.11.noarch and it simply CANNOT be
removed because 'rpm -e' comes back and states that the damn thing is
not installed- when it is! :-) :-( .

And I will try removing the ones you mention above.

I deleted the files you mentioned above and OO3.0.1.2 now appears to
work.

I'll now go and see which files WERE updated a few hours ago -- but I do
know that a number of 3009 files were still installed the last time I
looked (before I gave my self a break and watched a DVD :-) ).

<Shakes head in disbelief>

Just had a look in Software Management and found that the OO files have
been now updated to 3012 - which was not the case when I posted my
original message. Looks like the automatic daily Online Update 'jumped
in' and did some updating while I was watching the DVD.

(All I now need to do is to find out why I have been getting this for
the past several days:

#### YaST2 conflicts list - generated 2009-01-31 23:43:50 ####

compiz-kde4-0.7.8-28.1.i586 requires libplasma.so.2, but this
requirement cannot be provided

Right. libplasma.so.2 is from kde 4.1, and you have updated to kde 4.2

This was one of the conflicts that I mentioned, that you claimed you had never
seen. You must have just hit "ignore" on it

Just uninstall compiz-kde4 until they release a new version for kde 4.2 (or
just start using the effects built into kwin)

Anders
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups