Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] Video queston????
  • From: Sunny <sloncho@xxxxxxxxx>
  • Date: Fri, 30 Jan 2009 11:03:53 -0600
  • Message-id: <e7eeb230901300903y6b3abdabma8a0cde300ab71d6@xxxxxxxxxxxxxx>
On Fri, Jan 30, 2009 at 10:32 AM, James Hatridge <James.Hatridge@xxxxxx> wrote:
Hi all,

I have some mpg video files that I'm trying to figure out. My DVD player says
that MPG is the wrong format, so I'm using Avidemux to change the format from
MPG to avi. BUT it still will not work. I set Avidemux to "Mpeg-4
ASP(Xvid4)". This setting works when I change a FLV to avi.

MPG File:
file 1x00.mpg
1x00.mpg: RIFF (little-endian) data, AVI, 352 x 240, 23.98 fps, video: DivX 4,
audio: MPEG-1 Layer 3 (stereo, 22050 Hz)

SAME File as AVI:
file Show-00.avi
Show-00.avi: RIFF (little-endian) data, AVI, 352 x 240, 23.98 fps, video:
XviD, audio: MPEG-1 Layer 3 (stereo, 22050 Hz)

THIS FILE works on my DVD Player:
file TEST.avi
TEST.avi: RIFF (little-endian) data, AVI, 320 x 240, ~30 fps, video: XviD,
audio: MPEG-1 Layer 1 or 2 (mono, 32000 Hz)


The two AVI files look about the same but the first dones not work. Any ideas?

Thanks,


Check if the Mp3 sound stream is CBR (constant bitrate) or VBR
(variable bitrate). I have seen players to choke on VBR. Your third
file has converted the sound, so looks like there is the problem.

If I'm right, and the audio is VBR, then using avidemux, use "copy"
for video codec, and lame for audo to convert it to CBR, and avi
container.

Cheers

--
Svetoslav Milenov (Sunny)

Even the most advanced equipment in the hands of the ignorant is just
a pile of scrap.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References