Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] Samba Help
  • From: Tim Wunder <tim@xxxxxxxxxxxxxx>
  • Date: Mon, 26 Jan 2009 19:50:44 -0500
  • Message-id: <200901261950.47907.tim@xxxxxxxxxxxxxx>
On Monday 26 January 2009 07:40:18 pm Donald D Henson wrote:
(Earth-svr:/home/dhenson/Desktop # uname -a
Linux Earth-svr 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686
i686 i386 GNU/Linux)

Yes, I'm the guy who asked for Samba help before and I'm still
struggling with it. I've googled the web and found several howtos and
have attempted to follow their instructions. I installed Swat and played
around with that. Finally, I discovered GAdmin-Samba. Not much help
there either. I decided to try yet another restart, forgot the 're', and
got the following responses. This looks like a clue but I can't figure
out what it's trying to tell me. Would someone have a look at the
exchanges below and tell me if it really is a clue or am I still
clueless. (Sorry. I couldn't resist.) Aany help appreciated.

Earth-svr:/home/dhenson/Desktop # service smb start
Starting Samba SMB daemon - Warning: /var/run/samba/smbd.pid exists. done
Earth-svr:/home/dhenson/Desktop # service smb restart
Shutting down Samba SMB daemon Warning: daemon not running. done
Starting Samba SMB daemon - Warning: /var/run/samba/smbd.pid exists. done
Earth-svr:/home/dhenson/Desktop #

Looks like the smbd.pid exists in /var/run/samba/ but the deamon isn't
running.

What's 'service smdb status' tell you?

Or, how about 'ps -ef |grep smbd' ?

I'm guessing you could remove the .pid file and try starting samba.

Tim

< Previous Next >
Follow Ups
References