Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
[opensuse] Grub Confusion
  • From: Jim Flanagan <linuxjim@xxxxxxxxxx>
  • Date: Mon, 26 Jan 2009 11:39:23 -0600
  • Message-id: <497DF54B.6050103@xxxxxxxxxx>
I'm having confusion with Grub (will try to keep this from seeming like a shell game). I've got two 11.0 installs. When I do updates on one (esp kernel) the other one won't boot after restart. Just using Suse updater here. The first install on sda2 was upgraded from a previous 10.3 install. The second was a fresh test install of 11.0 on sda6.

Originally I had the 10.3 install on sda2. Then I did the fresh test install of 11.0 on sda6. At that point grub was booting both installs fine, and the 11.0 grub on sda6 was updated after kernal updates, for both installs. However after I did the upgrade on sda2 from 10.3 to 11.0, the references to initrd... and vmlinuz... are not being updated, Yast is getting confused. This is worsened by the confusion I'm having over straitening this out. When I do a kernel update on sda2, it changes the sda2/boot/grub/menu.1st, but the MBR does not get updated, it is taking that from sda6/boot. If I do an kernel upgrade on sda6, it will update the booting grub, but then I can't boot into the sda2 install( the one I use).

So, I have several times since, manually updated the /boot/grub/menu.1st on sda6 pointing it to the right boot parameters on sda2, but would like to straighten this out for good. I can delete the test install on sda6, but want to make sure I have the correct grub files on sda2. What is the best way for me to fix this issue?

TIA,

Jim F

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups