Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] bug in kernel-source-2.6.27.13-2.1 from http://download.opensuse.org/repositories/Kernel:/HEAD/openSUSE_Factory/
On Mon, 26 Jan 2009 07:03:18 -0800, Rainer Klier <r.klier@xxxxxxxxx> wrote:

hi list,

i think, there is a bug in the latest factory-kernel 2.6.27.13-2 from http://download.opensuse.org/repositories/Kernel:/HEAD/openSUSE_Factory/.

at least the kernel source has a bug, i think.

i tried to install latest nvidia-driver 180.22 on an opensuse11.1 x86_64 system.
former kernel 2.6.27.12-1 had no problems with this.
but this time, it was not possible to load nvidia kernel module.

the installation-script stopped, and told me that the built kernel module can't be loaded.

there were also warnings about missing symbols at compile time.

this is the relevant part of dmesg-output when loading the driver:
nvidia: Unknown symbol pv_mmu_ops
nvidia: Unknown symbol pv_cpu_ops
nvidia: Unknown symbol pv_irq_ops
nvidia: Unknown symbol pv_lock_ops

it seems, the above symbols are missing.

this was not the case with 2.6.27.12-1.

i had to downgrade kernel to latest available 2.6.27.7-9 from oss-repo.
with this version building the nvidia driver also was no problem.
right now i am writing this mail with this setup.

there must have been some changes between 2.6.27.12-1 and 2.6.27.13-2 which have something to do with these missing symbols.

does anybody know anything about this error?

Have you filed into http://bugzilla.novell.com ?
--
I say never be complete. I say stop being perfect. I say let's evolve. Let the
chips fall where they may. -Fight Club


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References