Mailinglist Archive: opensuse (3536 mails)

< Previous Next >
Re: [opensuse] NFS idmapping daemon, autofs problem
  • From: "Jason Bailey, Sun Advocate Webmaster" <webmaster@xxxxxxxxx>
  • Date: Mon, 19 Jan 2009 20:00:40 -0700
  • Message-id: <49753E58.8000902@xxxxxxxxx>
james Wright wrote:
On 1/19/09, Jason Bailey, Sun Advocate Webmaster <webmaster@xxxxxxxxx> wrote:
james Wright wrote:
On 1/19/09, Jason Bailey, Sun Advocate Webmaster <webmaster@xxxxxxxxx>
wrote:

I've not tried putting my NFS mount options in fstab because I've had
problems doing that before. I seem to recall that at the time that fstab
was processed before network services loaded, so the NFS mount could
never be discovered/found, and it would error out.

Autofs has worked very well for me and I'd like to keep using that.

When I do a directory listing on the remote NFS share, I don't get
"nobody" - I get numbers. But I can verify idmapd isn't starting.
/snipped/
Did you create/edit /etc/auto.master? I doubt you would need to, but
you may also want to take a look at /etc/idmapd.conf.
/snipped/
Yes, my /etc/imapd.conf and /etc/auto.master are set up correctly.

The thing is, the NFS mount is there... it works just fine.... except,
well, when I do a directory listing, I see things like this:

-rw-r--r-- 1 4294967294 4294967294 13944 2009-01-19 15:14 file1.jpg
-rw-r--r-- 1 4294967294 4294967294 17472 2009-01-19 17:13 file2.jpg
-rw-r--r-- 1 4294967294 4294967294 26589 2009-01-19 14:44 file3.jpg

Instead of "4294967294" I should be seeing the owning user and group,
like "joe" and "users" - you get the idea.

I know it's because idmapd isn't running. The problem is,
/etc/init.d/nfs won't load idmapd because I have no NFS mounts in
/etc/fstab, and I can't seem to invoke idmapd directly. This was not the
case with opensuse 11.0 or 10.3.

I assume that you are not then using NIS? My guess is that you do not
have a user/group with UID 4294967294.

No, I'm not using NIS, and no, I don't have a user with ID 4294967294.
But I can SSH into the server (i.e. the box hosting the NFS
share/export) and verify that 4294967294 is not the owning UID or GID of
** any ** of the files on that share/export.

My user on the server and workstation share the same UID ... i.e. 1000.
The server shows ownership and permissions properly on the server's end
of the picture.

In fact, it appears that the permissions are being interpreted correctly
by the workstation, because files that are owned by UID 1000 can be
edited on the workstation, but files that UID 1000 does not have
permission to don't open. I think it's simply a labeling issue since
idmapd isn't running.

I've tried running the idmapd binary directly but it doesn't seem to do
anything. I know NFS has varied components and I figure I'm probably not
starting it correctly. Again, I usually just do '/etc/init.d/nfs start',
which starts idmapd... but I can't do that on opensuse 11.1.

And, in case you're wondering, I'm using sec=sys on the workstation
mount. Server = SLES 10 SP2, workstation = opensuse 11.1.

Ideas?
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups