Mailinglist Archive: opensuse (3513 mails)

< Previous Next >
Re: [opensuse] Installing openSuSE v11.1 on T21 -- Revisited
  • From: Stan Goodman <stan.goodman@xxxxxxxxxxxxx>
  • Date: Sun, 11 Jan 2009 12:14:06 +0200
  • Message-id: <200901111214.06230.stan.goodman@xxxxxxxxxxxxx>
At 21:27:53 on Wednesday Wednesday 07 January 2009, Felix Miata
<mrmazda@xxxxxx> wrote:
On 2009/01/07 19:40 (GMT+0200) Stan Goodman composed:
I posted the earlier phases of this adventure here about a month ago,
and have since "progressed", but always with similar results in the
end.

It quickly became clear that the DVD drive had failed in the middle
of the installation, and I replaced it. Using the Installation DVD, I
ran the installation-media verification routine, and found that it
was defective (I have checked the iso file's MD5 code before I burned
it), so I burned another and verified it successfully. I then
installed v11.1 from this valid DVD.

Installation and configuration proceeded normally, but instead of
rebooting to present me with a finished system, it stalled with a
dark screen and unblinking cursor in the upper-left corner. A five
minute wait convinced me that it was going nowhere.

On many systems that blinking cursor is the result of missing boot code
in the MBR, or the lack of a startable/active primary partition that
has a properly installed boot loader. Better systems instead of that
nothingness will provide a message to the effect that nothing bootable
is available.

Any idea how much happens before you reach the blinking cursor? Can you
tell from disk activity that it does things for a while before halting?
Possibly there's a problem related to your video chip.
https://bugzilla.novell.com/show_bug.cgi?id=336302 might apply

(Two previous installations with the unverified DVD got further than
this, in one case bringing up a finished system which I was able to
use for the rest of the evening, but which failed to boot the
following morning.)

In order to try diagnose the reason for all this, I installed Windows
XP, using the entire 20GB HD. This installed faultlessly, and ran
perfectly, even after two shutdowns and reboots. I interpret this as
meaning that I do not have a hardware problem.

I have found time to try to investigate the problem further, starting from
the assumption that it lies in the video driver. I first tried to install
v11.0, in the hope that the slightly older release would support the
driver; it doesn't, and the result is as before.

I next tried to boot to the Fail-Safe system. This brings up a desktop
(the first I have seen). It has an introductory screen that has a Close
button. Unfortunately, the mouse cursor is not responsive, nor is the
keyboard, so this is only a modest advance.

But booting to the Rescue choice on the installation disk brought me to a
level-3 boot, so now I know how to examine the system in text mode. What
I want to do now is to find exactly what the video card is, so I can look
into (hopefully) more modern driver releases that might even (dare I
hope) enable me to boot a desktop. It is my understanding that
information on the hardware and drivers is located in file xorg.conf. So
I changed <cd /> and then did <find -name "xorg.conf">, which only brings
me back to the Rescue prompt. (Substituting "xorg.*" does the same
thing.)

At this stage, I am asking for advice on how I can identify the video
system. After I look into later driver releases, I may be back to ask
other questions.

--
Stan Goodman
Qiryat Tiv'on
Israel
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups