Mailinglist Archive: opensuse (3513 mails)

< Previous Next >
Re: [opensuse] Strange "PermissionDeniedByPolicy" Problem with 11.1
  • From: Josef Reidinger <jreidinger@xxxxxxx>
  • Date: Thu, 08 Jan 2009 09:01:06 +0100
  • Message-id: <4965B2C2.90003@xxxxxxx>
Rainer Krienke wrote:
Hello,

I recently installed a new 11.1 system using autoyast which basically worked
fine. However working with KDE i noticed a strange problem when trying to
supend the machine to disk.

Eg if I type (not beeing root) suspend -U in a KDE-terminal window I get the
message:

Error org.freedesktop.Hal.Device.PermissionDeniedByPolicy:
org.freedesktop.hal.power-management.hibernate no <-- (action, result)

When I am logged on beeing root then everything is OK. So its after all a
rights problem. Originally I tried to use kopwersave, but this tool disables
to corresponding menu entrys right from the start.

Another problem happens when accessing an USB stick. When I attach such a
device I get a notification in KDE that there is a new device but if I try to
open it using dolphin, then dolphin says:

org.freedesktop.Hal.Device.PermissionDeniedByPolicy:
org.freedesktop.hal.storage.mount-fixed no <- (action, result)

How can I debug this bug to find out what is going wrong? Where do I find the
configuration that says who is allowd to mount a device.

I guess this has something to do with the autoyast installation, since I have
two systems installed this way and both show these symptoms and another
system
installed without autoyast and there I do not have these problems.

How can I gon on to find the problem?

Any ideas are welcome.

Thanks
rainer

This looks for me like dbus permission problem. You can see
/etc/dbus-1/system.d/hal.conf if you have permission to action which is
shown in error message.
JR
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References