Mailinglist Archive: opensuse (3513 mails)

< Previous Next >
Re: [opensuse] Finding a modem
  • From: Simon Roberts <thorpflyer@xxxxxxxxx>
  • Date: Tue, 6 Jan 2009 09:35:00 -0800 (PST)
  • Message-id: <986425.10126.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
----- Original Message ----

From: Boris Epstein <borepstein@xxxxxxxxx>
..
I'm having very basic trouble with a modem card. It's an old one, and it's
possible it's dead, misconfigured, or otherwise not functioning.

However, my problem is more basic than that, even. I can see from hwinfo
that
the thing was probed successfully, and it has created /dev/ttyS0 and
/dev/ttyS1,
but I don't know which is the modem, and which the serial port, and I am
having
difficulty finding out.

I tried using minicom to connect to the thing and sending it "AT" and "ATZ"
commands (memory vaguely suggested that one of these was supposed to get a
reply
from the modem) but I couldn't get a response out of either /dev/ttyS0 or S1.

Any suggestions on how to identify it, or determine if the card is in fact
misconfigured in some critical way (or dead)?

...
Sounds like what you are doing is right... Been awhile since I played
with modems. This may be a dumb suggestion - likely is - but have you
checked the permissions on the tty device files to make sure you have
the proper access?

Hmm, I don't think that's my problem; it (minicom) doesn't complain of access
rights, and I ran it as root as is necessary for the configuration phase.

Thanks,
Simon



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >