Mailinglist Archive: opensuse (2343 mails)

< Previous Next >
Re: [opensuse] OS 11.1 / KDE4 - keyboard lockup
  • From: "Greg Freemyer" <greg.freemyer@xxxxxxxxx>
  • Date: Mon, 5 Jan 2009 14:16:33 -0500
  • Message-id: <87f94c370901051116m4cbb0502odc4b86462364515@xxxxxxxxxxxxxx>
On Mon, Jan 5, 2009 at 2:08 PM, Hylton Conacher (ZR1HPC)
<hyltonconacher@xxxxxxxxx> wrote:
2009/1/5 Greg Freemyer <greg.freemyer@xxxxxxxxx>:
On Fri, Nov 14, 2008 at 7:20 PM, Greg Freemyer <greg.freemyer@xxxxxxxxx>
On Fri, Nov 14, 2008 at 4:40 PM, Patrick Shanahan <paka@xxxxxxxxxxxx> wrote:
* Greg Freemyer <greg.freemyer@xxxxxxxxx> [11-14-08 15:22]:

i'm sure a reboot will fix my problem, but for experimentation sake
i'm trying to avoid that.

i'm running os 11.0 fully patched and my usb keyboard has quit
allowing me to type chars that require a shift key. and the caps lock
does not work.

i also have vmware instance with xp in it. the shift key is working
fine in there, so obviously the hardware is fine.

i have tried removing an re-inserting my usb cable. no effect.

any other ideas before i get frustrated and reboot.

maybe: rckbd restart

should re-read the keyboard configuration, and you might try reload
first instead of restart?

The above only happened once with 11.0

Since upgrading to 11.1, I have had the keyboard totally lockup on me
twice now. ie. Not just the shift key etc, Nothing on the keyboard
is working during these lockups.

I'm running KDE 4. I don't currently have any remote access to my
desktop machine setup, so the only solution I have had is to use the
mouse to logout of KDE. Once the login prompt comes up, I am able to
type again and enter my password.

I'm still using a USB keyboard and I have attempted to unplug / replug
the usb connector. It has no impact.

Is this a known problem?

Its known to the users :)

As to a work around I have other machines at the office, so I'm going
to enable sshd and will try to remotely login and do the rckbd restart
the next time it happens.

I am running 11.0 here and recently I am sure you saw my posts about
my kb locking up directly after login.

The fix for me was to rename the ~/.kde4 directory using the same user
but on a different window manager. Log out. Then log back in using
KDE4 and you should have full access to the kb, at least it worked on
11.0. You will then need to redo all your desktop/window settings.

It would seem that the KDE4 window manager is broken and causing this.


My situation is slightly different. Once I logout via the mouse, my
keyboard becomes operational again even after I log back into KDE4.

Greg Freemyer
Litigation Triage Solutions Specialist
First 99 Days Litigation White Paper -

The Norcross Group
The Intersection of Evidence & Technology
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >